package/mrp: new package
authorHoratiu Vultur <horatiu.vultur@microchip.com>
Mon, 31 Aug 2020 18:25:40 +0000 (20:25 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 6 Sep 2020 14:38:02 +0000 (16:38 +0200)
Signed-off-by: Horatiu Vultur <horatiu.vultur@microchip.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/mrp/Config.in [new file with mode: 0644]
package/mrp/mrp.hash [new file with mode: 0644]
package/mrp/mrp.mk [new file with mode: 0644]

index b2d69cfc52c8095aa6f90bd994411f635a1526ad..c01267960011fe09a5abd8f98126518e4e527a12 100644 (file)
@@ -1134,6 +1134,7 @@ F:        package/squeezelite/
 
 N:     Horatiu Vultur <horatiu.vultur@microchip.com>
 F:     package/easyframes/
+F:     package/mrp/
 
 N:     Ian Haylock <haylocki@yahoo.co.uk>
 F:     package/python-rpi-gpio/
index 9ee53aba47f1b78fcb3f7596ad94554b841eb05b..e5019e3ed69f09b5bca955ff5c62ba1c9e494ca5 100644 (file)
@@ -2135,6 +2135,7 @@ menu "Networking applications"
        source "package/mosh/Config.in"
        source "package/mosquitto/Config.in"
        source "package/mrouted/Config.in"
+       source "package/mrp/Config.in"
        source "package/mtr/Config.in"
        source "package/nbd/Config.in"
        source "package/ncftp/Config.in"
diff --git a/package/mrp/Config.in b/package/mrp/Config.in
new file mode 100644 (file)
index 0000000..0ca18a4
--- /dev/null
@@ -0,0 +1,17 @@
+config BR2_PACKAGE_MRP
+       bool "mrp"
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_5_0
+       select BR2_PACKAGE_LIBEV
+       select BR2_PACKAGE_LIBMNL
+       select BR2_PACKAGE_LIBNL
+       help
+         This is the userspace application that configures the kernel
+         to run MRP protocol. The userspace application is made of 2
+         applications, one daemon and a client.
+
+         https://github.com/microchip-ung/mrp
+
+comment "mrp needs a toolchain w/ threads, kernel headers >= 5.0"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS \
+               || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_5_0
diff --git a/package/mrp/mrp.hash b/package/mrp/mrp.hash
new file mode 100644 (file)
index 0000000..02a848c
--- /dev/null
@@ -0,0 +1,3 @@
+# locally calculated
+sha256  1a6c76d058bb425a7ec8b69a65de797650961161ec016b51ac8a1965e1ac304f  mrp-1.1.tar.gz
+sha256  8177f97513213526df2cf6184d8ff986c675afb514d4e68a404010521b880643  LICENSE
diff --git a/package/mrp/mrp.mk b/package/mrp/mrp.mk
new file mode 100644 (file)
index 0000000..4d8a1fc
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# mrp
+#
+################################################################################
+
+MRP_VERSION = 1.1
+MRP_SITE = $(call github,microchip-ung,mrp,v$(MRP_VERSION))
+MRP_DEPENDENCIES = libev libmnl libnl
+MRP_LICENSE = GPL-2.0
+MRP_LICENSE_FILES = LICENSE
+
+$(eval $(cmake-package))