Remove code specific to removed architectures
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 11 Aug 2010 13:43:30 +0000 (15:43 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 31 Aug 2010 18:28:21 +0000 (20:28 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
fs/jffs2/Config.in
package/liboil/liboil.mk
package/ltrace/Config.in
package/openssl/openssl.mk
toolchain/gcc/Config.in
toolchain/toolchain-common.in

index b787ec9d18b69d007aafa54d781d2fca1941bfcc..de137688176ee1cf48406a6ae9376dcd816a15fc 100644 (file)
@@ -95,10 +95,10 @@ config BR2_TARGET_ROOTFS_JFFS2_PADSIZE
 
 choice
        prompt "Endianess"
-       default BR2_TARGET_ROOTFS_JFFS2_BE if BR2_alpha || BR2_armeb || \
+       default BR2_TARGET_ROOTFS_JFFS2_BE if BR2_armeb || \
                        BR2_avr32 || BR2_m68k || BR2_mips || \
                        BR2_powerpc || BR2_sh2a_nofpueb || BR2_sh2eb || \
-                       BR2_sh3eb || BR2_sh4eb || BR2_sparc || BR2_sparc64
+                       BR2_sh3eb || BR2_sh4eb || BR2_sparc
 
 config BR2_TARGET_ROOTFS_JFFS2_LE
        bool "little-endian"
index 1bb412fc56d981d2998670cc10bb52c4db4864f4..44017bed68c5e627e10f9ff956408fecf74d02e9 100644 (file)
@@ -16,9 +16,6 @@ LIBOIL_INSTALL_TARGET = YES
 ifeq ($(BR2_avr32),y)
 LIBOIL_CONF_ENV = as_cv_unaligned_access=no
 endif
-ifeq ($(BR2_cris),y)
-LIBOIL_CONF_ENV = as_cv_unaligned_access=yes
-endif
 ifeq ($(BR2_x86_64),y)
 LIBOIL_CONF_ENV = as_cv_unaligned_access=yes
 endif
index 10a0e0aa52eb79d7b69a1d3195c0694e3d05a4d3..9e71d827a55e28426556cd963756bf5c3e00a676 100644 (file)
@@ -1,6 +1,6 @@
 config BR2_PACKAGE_LTRACE
        bool "ltrace"
-       depends on !(BR2_avr32 || BR2_cris || BR2_mips || BR2_mipsel || BR2_sh || BR2_sh64 || BR2_xtensa)
+       depends on !(BR2_avr32 || BR2_mips || BR2_mipsel || BR2_sh || BR2_sh64 || BR2_xtensa)
        select BR2_PACKAGE_LIBELF
        help
          Debugging program which runs a specified command until it exits.
index edbfe8b4fec28f84226b8e01a5dcdfdd05b85b7e..22b14f255cfdc8c88963a064a1ad3365d1ec54aa 100644 (file)
@@ -11,9 +11,6 @@ OPENSSL_DEPENDENCIES = zlib
 OPENSSL_TARGET_ARCH=generic32
 
 # Some architectures are optimized in OpenSSL
-ifeq ($(ARCH),ia64)
-OPENSSL_TARGET_ARCH=ia64
-endif
 ifeq ($(ARCH),powerpc)
 OPENSSL_TARGET_ARCH=ppc
 endif
index 70d8de9dbb196ccb4846d870c39af48007cfe0e5..760bb9823c0738183dc2cbe713eec730139f2ac4 100644 (file)
@@ -93,7 +93,7 @@ config BR2_GCC_SHARED_LIBGCC
        bool "Build/install a shared libgcc?"
        depends on !BR2_PREFER_STATIC_LIB
        default y
-       depends on !BR2_sparc && !BR2_sparc64
+       depends on !BR2_sparc
        help
          Build/install a shared libgcc library
 
index ea06acefa179ff3321930ca8b1d1c0b5c9874981..f67c30aa594fa51c288adddee42a14e9ba45c6eb 100644 (file)
@@ -9,7 +9,6 @@ comment "Common Toolchain Options"
 
 config BR2_LARGEFILE
        bool "Enable large file (files > 2 GB) support?"
-       depends on !BR2_cris
        help
          If you are building your own toolchain and you want to 
          support files larger than 2GB then enable this option.