qtopia4: add kconfig option to enable Phonon
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Mon, 8 Dec 2008 18:00:54 +0000 (18:00 -0000)
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Mon, 8 Dec 2008 18:00:54 +0000 (18:00 -0000)
This patch adds a kconfig option to enable Phonon when configuring Qt.

Phonon is the multimedia API from KDE 4 which has been integrated into
Qt 4.4. For playback under Linux the GStreamer multimedia framework is
used.

Signed-off-by: Markus Heidelberg <markus.heidelberg@web.de>
Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
package/qtopia4/Config.in
package/qtopia4/qtopia4.mk

index fb156af3da19f21c9e91551fa113290964fe28ab..2cd6e17b47ecb0c42af341eb8236f08a4c82ec90 100644 (file)
@@ -228,6 +228,15 @@ source "package/qtopia4/Config.sql.in"
 source "package/qtopia4/Config.gfx.in"
 source "package/qtopia4/Config.mouse.in"
 
+config BR2_PACKAGE_QTOPIA4_PHONON
+       bool "Phonon Module"
+       select BR2_PACKAGE_GSTREAMER
+       select BR2_PACKAGE_GST_PLUGINS_BASE
+       help
+         Build the Phonon module. Support for different audio/video
+         formats can be configured at the GStreamer package.
+         If unsure, say n.
+
 config BR2_PACKAGE_QTOPIA4_XMLPATTERNS
        bool "XML Patterns Module"
        help
index 8e2465a336054dae5a3d30f239a59a9479cd89b6..8c3e487b59d8d5f8336e090ef2b786f55c108843 100644 (file)
@@ -262,6 +262,13 @@ else
 QTOPIA4_CONFIGURE+= -no-xmlpatterns
 endif
 
+ifeq ($(BR2_PACKAGE_QTOPIA4_PHONON),y)
+QTOPIA4_CONFIGURE+= -phonon
+QTOPIA4_DEP_LIBS+=gstreamer gst-plugins-base
+else
+QTOPIA4_CONFIGURE+= -no-phonon
+endif
+
 ifeq ($(BR2_PACKAGE_QTOPIA4_SVG),y)
 QTOPIA4_CONFIGURE+= -svg
 else
@@ -361,6 +368,10 @@ $(TARGET_DIR)/usr/lib/libQtCore.so.4: $(STAGING_DIR)/usr/lib/libQtCore.la
 ifeq ($(BR2_PACKAGE_QTOPIA4_SHARED),y)
        cp -dpf $(STAGING_DIR)/usr/lib/libQt*.so.* $(TARGET_DIR)/usr/lib/
        -$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libQt*.so.*
+ifeq ($(BR2_PACKAGE_QTOPIA4_PHONON),y)
+       cp -dpf $(STAGING_DIR)/usr/lib/libphonon.so.* $(TARGET_DIR)/usr/lib/
+       -$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/lib/libphonon.so.*
+endif
 endif
        # Install image plugins if they are built
        if [ -d $(STAGING_DIR)/usr/plugins/imageformats ]; then \
@@ -368,6 +379,11 @@ endif
                cp -dpfr $(STAGING_DIR)/usr/plugins/imageformats $(TARGET_DIR)/usr/plugins/; \
                $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/plugins/imageformats/*; \
        fi
+ifeq ($(BR2_PACKAGE_QTOPIA4_PHONON),y)
+       mkdir -p $(TARGET_DIR)/usr/plugins
+       cp -dpfr $(STAGING_DIR)/usr/plugins/phonon_backend $(TARGET_DIR)/usr/plugins/
+       $(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/usr/plugins/phonon_backend/*
+endif
 ifneq ($(BR2_PACKAGE_QTOPIA4_SQL_MODULE),y)
        # Remove Sql libraries, not needed
        -rm $(TARGET_DIR)/usr/lib/libQtSql*