- revert part of 20119 (renaming BR2_ARM_.ABI to BR2_.ABI)
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sat, 29 Sep 2007 21:22:23 +0000 (21:22 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sat, 29 Sep 2007 21:22:23 +0000 (21:22 -0000)
12 files changed:
target/Config.in.arch
target/device/Arm/Config.in
target/device/Arm/Makefile.in
target/device/Arm/integrator926_defconfig
target/device/Arm/integrator926_huge_defconfig
target/device/Atmel/at91rm9200df/at91rm9200df_defconfig
target/device/Atmel/at91sam9260dfc/at91sam9260dfc_defconfig
target/device/Atmel/at91sam9260pf/at91sam9260pf_defconfig
target/device/Atmel/at91sam9261ek/at91sam9261ek_defconfig
target/linux-experimental/Makefile.in
target/linux/Makefile.in
toolchain/uClibc/uclibc.mk

index a6d611912d8882b76e518455092d2b8d4ffe8655..a4d03736dc30da2e791e074345bf84ab988e9c0f 100644 (file)
@@ -111,13 +111,13 @@ config BR2_ARM_TYPE
 choice
        prompt "Target ABI"
        depends BR2_arm || BR2_armeb
-       default BR2_OABI
+       default BR2_ARM_OABI
        help
          Application Binary Interface to use
 
-config BR2_OABI
+config BR2_ARM_OABI
        bool "OABI"
-config BR2_EABI
+config BR2_ARM_EABI
        bool "EABI"
 endchoice
 
@@ -150,15 +150,15 @@ endchoice
 choice
        prompt "Target ABI"
        depends BR2_mips || BR2_mipsel
-       default BR2_EABI
+       default BR2_MIPS_EABI
        help
          Application Binary Interface to use
 
-config BR2_OABI
+config BR2_MIPS_OABI
        bool "OABI"
-config BR2_EABI
+config BR2_MIPS_EABI
        bool "EABI"
-config BR2_ABI64
+config BR2_MIPS_ABI64
        bool "N64"
 endchoice
 
@@ -683,17 +683,17 @@ config BR2_GCC_TARGET_ABI
        default aapcs           if BR2_arm_dunno
        default aapcs-linux     if BR2_arm_dunno
        default iwmmxt          if BR2_iwmmxt
-       default 32              if (BR2_mipsel || BR2_arm) && BR2_OABI
-       default n32             if BR2_mipsel && BR2_EABI
-       default o64             if BR2_mips && BR2_OABI
-       default eabi            if (BR2_mips || BR2_arm) && BR2_EABI
-       default 64              if BR2_mips && BR2_ABI64
-       default mmixware        if BR2_mmix && BR2_ABI_native
-       default gnu             if BR2_mmix && !BR2_ABI_native
-       default altivec         if BR2_powerpc && BR2_ABI_altivec
-       default no-altivec      if BR2_powerpc && BR2_ABI_no-altivec
-       default spe             if BR2_powerpc && BR2_ABI_spe
-       default no-spe          if BR2_powerpc && BR2_ABI_no-spe
-       default ibmlongdouble   if BR2_powerpc && BR2_ABI_ibmlongdouble
-       default ieeelongdouble  if BR2_powerpc && BR2_ABI_ieeelongdouble
+       default 32              if BR2_mipsel && BR2_MIPS_OABI
+       default n32             if BR2_mipsel && BR2_MIPS_EABI
+       default o64             if BR2_mips && BR2_MIPS_OABI
+       default eabi            if BR2_mips && BR2_MIPS_EABI
+       default 64              if BR2_mips && BR2_MIPS_ABI64
+       default mmixware        if BR2_mmix && BR2_MMIX_ABI_native
+       default gnu             if BR2_mmix && !BR2_MMIX_ABI_native
+       default altivec         if BR2_powerpc && BR2_PPC_ABI_altivec
+       default no-altivec      if BR2_powerpc && BR2_PPC_ABI_no-altivec
+       default spe             if BR2_powerpc && BR2_PPC_ABI_spe
+       default no-spe          if BR2_powerpc && BR2_PPC_ABI_no-spe
+       default ibmlongdouble   if BR2_powerpc && BR2_PPC_ABI_ibmlongdouble
+       default ieeelongdouble  if BR2_powerpc && BR2_PPC_ABI_ieeelongdouble
 
index de50fea7716603d798bb648455b49df6d846f2d6..36934ee0904314ed43726ca3295507a9492b63d7 100644 (file)
@@ -3,16 +3,15 @@ menuconfig BR2_TARGET_ARM
        depends BR2_arm
        default n
 
-if BR2_TARGET_ARM
 comment "Arm based Device Support"
-       depends BR2_arm
+       depends BR2_arm && BR2_TARGET_ARM
 
 config BR2_TARGET_ARM_INTEGRATOR_926
        bool "Integrator arm926"
-       depends BR2_arm
+       depends BR2_arm && BR2_TARGET_ARM
        default n
        select BR2_PACKAGE_LINUX
-       select BR2_EABI
+       select BR2_ARM_EABI
        select BR2_KERNEL_HEADERS_2_6_22
        select BR2_PTHREADS
        select BR2_arm926t
@@ -20,4 +19,3 @@ config BR2_TARGET_ARM_INTEGRATOR_926
          An ARM integrator 926 board for use with qemu.
          This one has an MMU.
 
-endif
index db1b8124016db086c03d439680bdd22304dd692b..a55389e7f421cafe2dfeea014bd8227017de317e 100644 (file)
@@ -7,7 +7,7 @@ UCLIBC_CONFIG_FILE:=target/device/Arm/uClibc.integrator926.config
 endif
 
 # pin some settings
-BR2_EABI:=y
+BR2_ARM_EABI:=y
 BR2_GNU_TARGET_SUFFIX:="linux-uclibcgnueabi"
 BR2_DEFAULT_KERNEL_HEADERS:="2.6.22.8"
 endif
index 2b4d9c6765d886819116b3163fa372a6141272c1..1977375ebd33474546d4acb812472fece649b5bb 100644 (file)
@@ -39,8 +39,8 @@ BR2_arm926t=y
 # BR2_xscale is not set
 # BR2_iwmmxt is not set
 BR2_ARM_TYPE="ARM926T"
-# BR2_OABI is not set
-BR2_EABI=y
+# BR2_ARM_OABI is not set
+BR2_ARM_EABI=y
 # BR2_x86_i386 is not set
 # BR2_x86_i486 is not set
 # BR2_x86_i586 is not set
index 72c0d07571bdee9f94accf0ecd57793c281144e4..43e436ca3c6c331680a6a3f164cbb948d77e5349 100644 (file)
@@ -39,8 +39,8 @@ BR2_arm926t=y
 # BR2_xscale is not set
 # BR2_iwmmxt is not set
 BR2_ARM_TYPE="ARM926T"
-# BR2_OABI is not set
-BR2_EABI=y
+# BR2_ARM_OABI is not set
+BR2_ARM_EABI=y
 BR2_ARCH="arm"
 BR2_ENDIAN="LITTLE"
 BR2_GCC_TARGET_TUNE="arm9tdmi"
index ddbf9b624739d44a63302733cf60052974e27ab1..38cdc8fcd9fcdc009900757dc490b24ada1a0d94 100644 (file)
@@ -153,8 +153,8 @@ BR2_GCC_VERSION_4_2_1=y
 BR2_GCC_SUPPORTS_SYSROOT=y
 # BR2_GCC_SUPPORTS_FINEGRAINEDMTUNE is not set
 BR2_GCC_VERSION="4.2.1"
-BR2_OABI=y
-# BR2_EABI is not set
+BR2_ARM_OABI=y
+# BR2_ARM_EABI is not set
 BR2_TOOLCHAIN_SYSROOT=y
 # BR2_GCC_USE_SJLJ_EXCEPTIONS is not set
 BR2_EXTRA_GCC_CONFIG_OPTIONS=""
index e11611d2566f9be0ead513e7c7fa97b4ec58589a..69afb804b5c9dc4b32be7aec12f9997ba4848b13 100644 (file)
@@ -42,8 +42,8 @@ BR2_generic_arm=y
 # BR2_xscale is not set
 # BR2_iwmmxt is not set
 BR2_ARM_TYPE="GENERIC_ARM"
-BR2_OABI=y
-# BR2_EABI is not set
+BR2_ARM_OABI=y
+# BR2_ARM_EABI is not set
 BR2_ARCH="arm"
 BR2_ENDIAN="LITTLE"
 
index 54af41f4062c226e514b96568167b9c957168166..36dd77a5befa60343bf72084db4d0a96d4f693c1 100644 (file)
@@ -44,8 +44,8 @@ BR2_generic_arm=y
 # BR2_xscale is not set
 # BR2_iwmmxt is not set
 BR2_ARM_TYPE="GENERIC_ARM"
-BR2_OABI=y
-# BR2_EABI is not set
+BR2_ARM_OABI=y
+# BR2_ARM_EABI is not set
 BR2_ARCH="arm"
 BR2_ENDIAN="LITTLE"
 
index 265eb0b917ce87950f4a3dd3bce8883bc3b6db0f..5558c2cf327beeca60825e91ac3d621f6dddbcd1 100644 (file)
@@ -44,8 +44,8 @@ BR2_generic_arm=y
 # BR2_xscale is not set
 # BR2_iwmmxt is not set
 BR2_ARM_TYPE="GENERIC_ARM"
-BR2_OABI=y
-# BR2_EABI is not set
+BR2_ARM_OABI=y
+# BR2_ARM_EABI is not set
 BR2_ARCH="arm"
 BR2_ENDIAN="LITTLE"
 
index bfad7c5b4ff22ce3de641a0182e941fbe173f83e..ab9a6135ddcb0b5c593f3888af1ea6ebb163e39f 100644 (file)
@@ -184,7 +184,7 @@ ifeq ($(strip $(BR2_LINUX_CUSTOMIZE)),y)
        make -C $(LINUX26_DIR) xconfig
 endif
        $(SED) '/CONFIG_AEABI/d' $(LINUX26_DIR)/.config
-ifeq ($(BR2_EABI),y)
+ifeq ($(BR2_ARM_EABI),y)
        echo "CONFIG_AEABI=y" >> $(LINUX26_DIR)/.config
        $(SED) '/CONFIG_OABI_COMPAT/d' $(LINUX26_DIR)/.config
        echo "# CONFIG_OABI_COMPAT is not set" >> $(LINUX26_DIR)/.config
index bf5b9492d1557bca53af67cc339de2fe4bd83b5d..14d4e085ed6c84aed77e17485c6dfd7025f5f517 100644 (file)
@@ -148,7 +148,7 @@ endif
 $(LINUX26_DIR)/.configured: $(LINUX26_DIR)/.patched $(LINUX26_KCONFIG)
        cp -dpf $(LINUX26_KCONFIG) $(LINUX26_DIR)/.config
        $(SED) '/CONFIG_AEABI=y/d' $(LINUX26_DIR)/.config
-ifeq ($(BR2_EABI),y)
+ifeq ($(BR2_ARM_EABI),y)
        echo "CONFIG_AEABI=y" >> $(LINUX26_DIR)/.config
        $(SED) '/CONFIG_OABI_COMPAT/d' $(LINUX26_DIR)/.config
        echo "# CONFIG_OABI_COMPAT is not set" >> $(LINUX26_DIR)/.config
index 2172d110306b72e3660950fd3a8d574f353c147b..1bef774f0c0550f9f6bbd26069d323b6d01a1a9e 100644 (file)
@@ -139,11 +139,11 @@ ifeq ($(UCLIBC_TARGET_ARCH),arm)
                 $(UCLIBC_DIR)/.oldconfig
        $(SED) 's/^.*$(UCLIBC_ARM_TYPE).*/$(UCLIBC_ARM_TYPE)=y/g' $(UCLIBC_DIR)/.oldconfig
        $(SED) '/CONFIG_ARM_.ABI/d' $(UCLIBC_DIR)/.oldconfig
-ifeq ($(BR2_EABI),y)
+ifeq ($(BR2_ARM_EABI),y)
        /bin/echo "# CONFIG_ARM_OABI is not set" >> $(UCLIBC_DIR)/.oldconfig
        /bin/echo "CONFIG_ARM_EABI=y" >> $(UCLIBC_DIR)/.oldconfig
 endif
-ifeq ($(BR2_OABI),y)
+ifeq ($(BR2_ARM_OABI),y)
        /bin/echo "CONFIG_ARM_OABI=y" >> $(UCLIBC_DIR)/.oldconfig
        /bin/echo "# CONFIG_ARM_EABI is not set" >> $(UCLIBC_DIR)/.oldconfig
 endif
@@ -154,13 +154,13 @@ ifeq ($(UCLIBC_TARGET_ARCH),mips)
         /bin/echo "# CONFIG_MIPS_N32_ABI is not set"; \
         /bin/echo "# CONFIG_MIPS_N64_ABI is not set"; \
        ) >> $(UCLIBC_DIR)/.oldconfig
-ifeq ($(BR2_OABI),y)
+ifeq ($(BR2_MIPS_OABI),y)
        $(SED) 's/.*\(CONFIG_MIPS_O32_ABI\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
 endif
-ifeq ($(BR2_EABI),y)
+ifeq ($(BR2_MIPS_EABI),y)
        $(SED) 's/.*\(CONFIG_MIPS_N32_ABI\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
 endif
-ifeq ($(BR2_ABI64),y)
+ifeq ($(BR2_MIPS_ABI64),y)
        $(SED) 's/.*\(CONFIG_MIPS_N64_ABI\).*/\1=y/' $(UCLIBC_DIR)/.oldconfig
 endif
 endif