wine: Add opengl dependency
authorAndré Hentschel <nerv@dawncrow.de>
Sat, 21 Mar 2015 15:38:23 +0000 (16:38 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 3 Apr 2015 22:18:05 +0000 (00:18 +0200)
Signed-off-by: André Hentschel <nerv@dawncrow.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/wine/wine.mk

index a699fff9539d188bf31c370e5156dc1b989aa241..bd242cffb0ef3aa78d5689054f62d921a6eca8f0 100644 (file)
@@ -26,7 +26,6 @@ WINE_CONF_OPTS = \
        --without-netapi \
        --without-openal \
        --without-opencl \
-       --without-opengl \
        --without-osmesa \
        --without-oss \
        --without-xshape \
@@ -110,6 +109,13 @@ else
 WINE_CONF_OPTS += --without-cms
 endif
 
+ifeq ($(BR2_PACKAGE_HAS_LIBGL),y)
+WINE_CONF_OPTS += --with-opengl
+WINE_DEPENDENCIES += libgl
+else
+WINE_CONF_OPTS += --without-opengl
+endif
+
 ifeq ($(BR2_PACKAGE_LIBGLU),y)
 WINE_CONF_OPTS += --with-glu
 WINE_DEPENDENCIES += libglu