sysstat: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 21:19:34 +0000 (23:19 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:35:41 +0000 (01:35 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - using TARGET_NLS_LIBS to force linking against libintl

 - dropping BR2_PACKAGE_GETTEXT selection

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/sysstat/Config.in
package/sysstat/sysstat.mk

index 923c48a1107f6ba23999d8000538fd3d57f8c800..442b7876843fe20b1128b4a5c31b161b0539bc69 100644 (file)
@@ -1,7 +1,6 @@
 config BR2_PACKAGE_SYSSTAT
        bool "sysstat"
        depends on BR2_USE_MMU  # fork()
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        help
          The sysstat utilities are a collection of performance
          monitoring tools for Linux. These include sar, sadf, mpstat,
index bd73214c3501a242fa461dfc6c1fc0975995cfe0..e4ba66264356de2914352943f1104d87e3c77324 100644 (file)
@@ -8,14 +8,10 @@ SYSSTAT_VERSION = 11.4.4
 SYSSTAT_SOURCE = sysstat-$(SYSSTAT_VERSION).tar.xz
 SYSSTAT_SITE = http://pagesperso-orange.fr/sebastien.godard
 SYSSTAT_CONF_OPTS = --disable-file-attr --disable-sensors
-SYSSTAT_DEPENDENCIES = host-gettext
+SYSSTAT_DEPENDENCIES = host-gettext $(TARGET_NLS_DEPENDENCIES)
 SYSSTAT_LICENSE = GPL-2.0+
 SYSSTAT_LICENSE_FILES = COPYING
-
-ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
-SYSSTAT_DEPENDENCIES += gettext
-SYSSTAT_MAKE_OPTS += LFLAGS="$(TARGET_LDFLAGS) -lintl"
-endif
+SYSSTAT_MAKE_OPTS += LFLAGS="$(TARGET_LDFLAGS) $(TARGET_NLS_LIBS)"
 
 # The isag tool is a post processing script that depends on tcl/tk
 # among other things. So we don't install it.