package/ipsec-tools: hybrid config support
authorDoug Kehn <rdkehn@yahoo.com>
Sun, 1 Feb 2015 05:26:52 +0000 (23:26 -0600)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 1 Feb 2015 22:24:55 +0000 (23:24 +0100)
Add config option for enabling hybrid mode.  Hybrid mode is required for
successful interoperability.

Signed-off-by: Doug Kehn <rdkehn@yahoo.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ipsec-tools/Config.in
package/ipsec-tools/ipsec-tools.mk

index a0d7600258be93255a55bce0e252c960b5dae7d1..4af40958434624fd60e85dd48cefabaf9f0b0660 100644 (file)
@@ -48,6 +48,12 @@ config BR2_PACKAGE_IPSEC_TOOLS_READLINE
        select BR2_PACKAGE_READLINE
        bool "Enable readline input support"
 
+config BR2_PACKAGE_IPSEC_TOOLS_HYBRID
+       bool "Enable hybrid, both mode-cfg and xauth support"
+       help
+         Hybrid mode is required for successful interoperability
+         (e.g. Cisco VPN Client).
+
 choice
        prompt "Security context"
        default BR2_PACKAGE_IPSEC_SECCTX_DISABLE
index d9160277dae2727ab1c38a3ae2cbbf9e15152987..56e2bed7fdce7258b54f617a467887c0f99145b5 100644 (file)
@@ -21,7 +21,6 @@ IPSEC_TOOLS_CONF_ENV += LIBS=-lz
 endif
 
 IPSEC_TOOLS_CONF_OPTS = \
-         --disable-hybrid \
          --without-libpam \
          --disable-gssapi \
          --with-kernel-headers=$(STAGING_DIR)/usr/include
@@ -62,6 +61,12 @@ else
 IPSEC_DEPENDENCIES += readline
 endif
 
+ifeq ($(BR2_PACKAGE_IPSEC_TOOLS_HYBRID), y)
+IPSEC_TOOLS_CONF_OPTS += --enable-hybrid
+else
+IPSEC_TOOLS_CONF_OPTS += --disable-hybrid
+endif
+
 ifeq ($(BR2_PACKAGE_IPSEC_SECCTX_DISABLE),y)
 IPSEC_TOOLS_CONF_OPTS += --enable-security-context=no
 endif