netsnmp: enable tsm + DTLSUDP/TLSTCP with openssl
authorGustavo Zacarias <gustavo.zacarias@free-electrons.com>
Wed, 9 Dec 2015 18:30:23 +0000 (15:30 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 12 Dec 2015 15:58:56 +0000 (16:58 +0100)
Otherwise the openssl support is basically unused.

net-snmp provides a stripped-down openssl implementation that can be
used to enable tsm/DTLSUDP/TLSTCP but given it's security track record
it's best to rely on the external one, it also saves space.

usm is the user validation module, it's default on, however when passing
--with-security-modules we must keep it otherwise it won't be.

Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/netsnmp/netsnmp.mk

index 6eff5e30163ed0a5735e8722c1a91aa01c035a55..fb7217964e7761f37699bee829f00a4f968417a3 100644 (file)
@@ -49,7 +49,9 @@ endif
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 NETSNMP_DEPENDENCIES += openssl
 NETSNMP_CONF_OPTS += \
-       --with-openssl=$(STAGING_DIR)/usr/include/openssl
+       --with-openssl=$(STAGING_DIR)/usr/include/openssl \
+       --with-security-modules="tsm,usm" \
+       --with-transports="DTLSUDP,TLSTCP"
 ifeq ($(BR2_STATIC_LIBS),y)
 # openssl uses zlib, so we need to explicitly link with it when static
 NETSNMP_CONF_ENV += LIBS=-lz