exfat: bump to version 1.2.1
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 19 Oct 2015 21:38:33 +0000 (18:38 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 20 Oct 2015 07:55:24 +0000 (09:55 +0200)
Switch to github homepage and site.
Package is now autotools-based.
musl tweak no longer required.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/exfat/Config.in
package/exfat/exfat.hash
package/exfat/exfat.mk

index 575f389ff0869c19c371603227e0e6079022aa3a..c0b4eabe11191650617c22da9f6412fc422b5267 100644 (file)
@@ -9,7 +9,7 @@ config BR2_PACKAGE_EXFAT
          A full-featured exFAT file system implementation for GNU/Linux
          and other Unix-like systems as a FUSE module.
 
-         http://code.google.com/p/exfat/
+         https://github.com/relan/exfat
 
 comment "exfat needs a toolchain w/ wchar, threads, dynamic library"
        depends on BR2_USE_MMU
index bfaca6e6d93536a4edf6bef9e48848702b4fad26..af6778514e6ce0dd4019f17ede50e28a55c1d77b 100644 (file)
@@ -1,2 +1,2 @@
-# From https://code.google.com/p/exfat/wiki/Downloads?tm=2
-sha1   060560f74dbce4dc947c7e658e75fdf339bc10ff        fuse-exfat-1.1.0.tar.gz
+# Locally calculated
+sha256 f444cd2849295b8de7fc61022fbf02f5bb1a84790c43f0c75ba3bf96f4619dd4        fuse-exfat-1.2.1.tar.gz
index 5508ec3a5f908718838108279fea59b0164a946c..cc474a764a77f6cbb6eece64fc5d8e6b6ad0ee59 100644 (file)
@@ -4,31 +4,12 @@
 #
 ################################################################################
 
-EXFAT_VERSION = 1.1.0
-EXFAT_SITE = http://distfiles.gentoo.org/distfiles
+EXFAT_VERSION = 1.2.1
+EXFAT_SITE = https://github.com/relan/exfat/releases/download/v$(EXFAT_VERSION)
 EXFAT_SOURCE = fuse-exfat-$(EXFAT_VERSION).tar.gz
-EXFAT_DEPENDENCIES = host-scons libfuse
+EXFAT_DEPENDENCIES = libfuse host-pkgconf
 EXFAT_LICENSE = GPLv3+
 EXFAT_LICENSE_FILES = COPYING
 EXFAT_CFLAGS = $(TARGET_CFLAGS) -std=c99
 
-# The endianness handling functions in platform.h are protected behind
-# ifdef __GLIBC__ which musl doesn't define even though it does
-# provide the endianness handling interface. Work around it by
-# ensuring __GLIBC__ is defined.
-ifeq ($(BR2_TOOLCHAIN_USES_MUSL),y)
-EXFAT_CFLAGS += -D__GLIBC__
-endif
-
-define EXFAT_BUILD_CMDS
-       (cd $(@D); \
-               $(TARGET_CONFIGURE_OPTS) CCFLAGS="$(EXFAT_CFLAGS)" $(SCONS))
-endef
-
-define EXFAT_INSTALL_TARGET_CMDS
-       (cd $(@D); \
-               $(TARGET_CONFIGURE_OPTS) CCFLAGS="$(EXFAT_CFLAGS)" $(SCONS) \
-               DESTDIR=$(TARGET_DIR)/usr/sbin install)
-endef
-
-$(eval $(generic-package))
+$(eval $(autotools-package))