package/systemd: support new v246 options
authorNorbert Lange <nolange79@gmail.com>
Fri, 31 Jul 2020 21:18:46 +0000 (23:18 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 5 Aug 2020 13:40:18 +0000 (15:40 +0200)
This adds switches for new options:

initrd: Installs services if systemd is used on an initramfs,
useless otherwise

kernel-install: helper scripts to update kernel with an
systemd-boot partition

analyze: tool to analyze bootup and dependencies

Signed-off-by: Norbert Lange <nolange79@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/systemd/Config.in
package/systemd/systemd.mk

index dd3b8c534de77a1c09aff49669f2438c1a7a2c49..30a5c960f5107d3d00dc6d8eaf7e1fb34d17cf28 100644 (file)
@@ -112,6 +112,30 @@ config BR2_PACKAGE_SYSTEMD_BOOT
 
          https://www.freedesktop.org/wiki/Software/systemd/systemd-boot/
 
+config BR2_PACKAGE_SYSTEMD_INITRD
+       bool "Services for booting from initrd"
+       help
+         Install various services that are only useful if systemd is
+         run from an initrd.
+
+config BR2_PACKAGE_SYSTEMD_KERNELINSTALL
+       bool "install kernel-install and related files"
+       help
+         kernel-install is used to install and remove kernel and
+         initramfs images to and from the boot loader partition.
+         The boot loader partition will usually be one of
+         /boot, /efi, or /boot/efi.
+
+config BR2_PACKAGE_SYSTEMD_ANALYZE
+       bool "systemd-analyze"
+       help
+         systemd-analyze may be used to determine system boot-up
+         performance statistics and retrieve other state and tracing
+         information from the system and service manager, and to
+         verify the correctness of unit files.
+         It is also used to access special functions useful for
+         advanced system manager debugging.
+
 config BR2_PACKAGE_SYSTEMD_BOOT_EFI_ARCH
        string
        default "ia32"  if BR2_i386
@@ -187,6 +211,7 @@ config BR2_PACKAGE_SYSTEMD_FIRSTBOOT
 
 config BR2_PACKAGE_SYSTEMD_HIBERNATE
        bool "enable hibernation support"
+       select BR2_PACKAGE_SYSTEMD_INITRD
        help
          When this features is enabled, additional tools and services
          are built to support suspending and resuming the system.
index 87265c97ad24bc5d4b0219de9038ca6648d1101e..00ab5fd383a570dd8c5a6f9c754197c53f75b0f0 100644 (file)
@@ -208,6 +208,24 @@ else
 SYSTEMD_CONF_OPTS += -Dpcre2=false
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD_INITRD),y)
+SYSTEMD_CONF_OPTS += -Dinitrd=true
+else
+SYSTEMD_CONF_OPTS += -Dinitrd=false
+endif
+
+ifeq ($(BR2_PACKAGE_SYSTEMD_KERNELINSTALL),y)
+SYSTEMD_CONF_OPTS += -Dkernel-install=true
+else
+SYSTEMD_CONF_OPTS += -Dkernel-install=false
+endif
+
+ifeq ($(BR2_PACKAGE_SYSTEMD_ANALYZE),y)
+SYSTEMD_CONF_OPTS += -Danalyze=true
+else
+SYSTEMD_CONF_OPTS += -Danalyze=false
+endif
+
 ifeq ($(BR2_PACKAGE_SYSTEMD_JOURNAL_GATEWAY),y)
 SYSTEMD_DEPENDENCIES += libmicrohttpd
 SYSTEMD_CONF_OPTS += -Dmicrohttpd=true