postgresql: uses fork(), needs mmu
authorPeter Seiderer <ps.report@gmx.net>
Tue, 17 Mar 2015 22:06:27 +0000 (23:06 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 17 Mar 2015 22:16:29 +0000 (23:16 +0100)
Additional revert 'postgresql: enable bfin compile' ([2]) which
is now useless (Blackfin is a noMMU architecture).

Fixes ([1]):
  postmaster/fork_process.o: In function `_fork_process':
  fork_process.c:(.text+0x22): undefined reference to `_fork'

[1] http://autobuild.buildroot.org/results/c9c/c9c93156fe64e89f35627aa592c47d8c5181ed7d
[2] http://git.buildroot.net/buildroot/commit/?id=6f177dac73a289db28772fb3e20347aba5cd5e67

[Thomas: propagate to the appropriate reverse dependencies.]

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/php/Config.ext
package/postgresql/Config.in
package/postgresql/postgresql.mk
package/qt5/qt5base/Config.in

index 935f966a1951c52367e783f8733c2f02cc27f842..1d9c2fe68f0910dcd20583c40fb9a580b7e6522a 100644 (file)
@@ -149,6 +149,7 @@ comment "MySQL drivers need a toolchain w/ C++, threads"
 config BR2_PACKAGE_PHP_EXT_PDO_POSTGRESQL
        bool "PostgreSQL"
        select BR2_PACKAGE_POSTGRESQL
+       depends on BR2_USE_MMU # postgresql
        help
          PDO driver for PostgreSQL
 
index 519b2a17a1627c979f17775a2b46590d7888c075..4c53703568285b12cfa57330166c4ac7b82fe118 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_POSTGRESQL
        bool "postgresql"
+       depends on BR2_USE_MMU # fork()
        help
          PostgreSQL is a powerful, open source object-relational
          database system.
index d426093a30cd037ea4aa809be608be42680c5a9f..7dc3f0bf029e54d0688f80303388e10d80a8b290 100644 (file)
@@ -13,11 +13,6 @@ POSTGRESQL_LICENSE_FILES = COPYRIGHT
 POSTGRESQL_INSTALL_STAGING = YES
 POSTGRESQL_CONFIG_SCRIPTS = pg_config
 
-# In most cases, postgresql configure script is able to guess the
-# platform, except for noMMU platforms that use the 'uclinux' host
-# qualifier, as is the case on Blackfin
-POSTGRESQL_CONF_OPTS = --with-template=linux
-
 ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
 # overwrite IPV6 detection
 ifeq ($(BR2_INET_IPV6),y)
@@ -36,7 +31,7 @@ ifneq ($(BR2_TOOLCHAIN_HAS_THREADS),y)
        POSTGRESQL_CONF_OPTS += --disable-thread-safety
 endif
 
-ifeq ($(BR2_bfin)$(BR2_microblazeel)$(BR2_microblazebe)$(BR2_nios2)$(BR2_xtensa),y)
+ifeq ($(BR2_microblazeel)$(BR2_microblazebe)$(BR2_nios2)$(BR2_xtensa),y)
        POSTGRESQL_CONF_OPTS += --disable-spinlocks
 endif
 
index 17ed5db077e06360f8a1f71ecc79875d7c36615f..20fd905849ddb489291a0626cccf3e7134bd9737 100644 (file)
@@ -60,6 +60,7 @@ config BR2_PACKAGE_QT5BASE_MYSQL
 config BR2_PACKAGE_QT5BASE_PSQL
        bool "PostgreSQL Plugin"
        select BR2_PACKAGE_POSTGRESQL
+       depends on BR2_USE_MMU # postgresql
        help
          Build PostgreSQL plugin
          If unsure, say n.