git: fix config option used to detect libcurl availability
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 4 Nov 2015 13:44:43 +0000 (14:44 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 4 Nov 2015 13:44:43 +0000 (14:44 +0100)
BR2_PACKAGE_CURL is currently used by the git package to find out if
libcurl is available. While indeed BR2_PACKAGE_CURL indicates that
libcurl is available, it is not the most appropriate option for this:
BR2_PACKAGE_LIBCURL is better. BR2_PACKAGE_LIBCURL indicates that
libcurl is available, while BR2_PACKAGE_CURL indicates that both
libcurl and the curl program are available. Only the former is needed
by Git.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/git/git.mk

index 2bd6a015819865402f008e3b1d2613daa41f3594..54f7fbf305fecbef83227278003314c2c32e2b97 100644 (file)
@@ -26,7 +26,7 @@ else
 GIT_CONF_OPTS += --without-libpcre
 endif
 
-ifeq ($(BR2_PACKAGE_CURL),y)
+ifeq ($(BR2_PACKAGE_LIBCURL),y)
 GIT_DEPENDENCIES += libcurl
 GIT_CONF_OPTS += --with-curl
 else