linux: Add custom Subversion repository support for the package
authorPauli Sundberg <susundberg@gmail.com>
Tue, 29 Mar 2016 17:22:58 +0000 (20:22 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 5 Apr 2016 20:28:09 +0000 (22:28 +0200)
Signed-off-by: Pauli Sundberg <susundberg@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
linux/Config.in
linux/linux.mk

index 49b6994fece3d843469656dccc94390cf4bd2af4..9f0267d13191534fa7fdcae0580f73ac20450733 100644 (file)
@@ -63,6 +63,12 @@ config BR2_LINUX_KERNEL_CUSTOM_HG
          This option allows Buildroot to get the Linux kernel source
          code from a Mercurial repository.
 
+config BR2_LINUX_KERNEL_CUSTOM_SVN
+       bool "Custom Subversion repository"
+       help
+         This option allows Buildroot to get the Linux kernel source
+         code from a Subversion repository.
+
 config BR2_LINUX_KERNEL_CUSTOM_LOCAL
        bool "Local directory"
        help
@@ -79,7 +85,7 @@ config BR2_LINUX_KERNEL_CUSTOM_TARBALL_LOCATION
        string "URL of custom kernel tarball"
        depends on BR2_LINUX_KERNEL_CUSTOM_TARBALL
 
-if BR2_LINUX_KERNEL_CUSTOM_GIT || BR2_LINUX_KERNEL_CUSTOM_HG
+if BR2_LINUX_KERNEL_CUSTOM_GIT || BR2_LINUX_KERNEL_CUSTOM_HG || BR2_LINUX_KERNEL_CUSTOM_SVN
 
 config BR2_LINUX_KERNEL_CUSTOM_REPO_URL
        string "URL of custom repository"
@@ -91,7 +97,7 @@ config BR2_LINUX_KERNEL_CUSTOM_REPO_VERSION
        default BR2_LINUX_KERNEL_CUSTOM_GIT_VERSION \
                if BR2_LINUX_KERNEL_CUSTOM_GIT_VERSION != ""  # legacy
        help
-         Revision to use in the typical format used by Git/Mercurial
+         Revision to use in the typical format used by Git/Mercurial/Subversion
          E.G. a sha id, a tag, branch, ..
 
 endif
@@ -109,7 +115,7 @@ config BR2_LINUX_KERNEL_VERSION
                if BR2_LINUX_KERNEL_CUSTOM_VERSION
        default "custom" if BR2_LINUX_KERNEL_CUSTOM_TARBALL
        default BR2_LINUX_KERNEL_CUSTOM_REPO_VERSION \
-               if BR2_LINUX_KERNEL_CUSTOM_GIT || BR2_LINUX_KERNEL_CUSTOM_HG
+               if BR2_LINUX_KERNEL_CUSTOM_GIT || BR2_LINUX_KERNEL_CUSTOM_HG || BR2_LINUX_KERNEL_CUSTOM_SVN
        default "custom" if BR2_LINUX_KERNEL_CUSTOM_LOCAL
 
 #
index 7e202559564fd92f8a40a301f883f9b0ab9e3e6d..317587f1df69ff9ffb860a9c68197210c044ff5c 100644 (file)
@@ -23,6 +23,9 @@ LINUX_SITE_METHOD = git
 else ifeq ($(BR2_LINUX_KERNEL_CUSTOM_HG),y)
 LINUX_SITE = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_REPO_URL))
 LINUX_SITE_METHOD = hg
+else ifeq ($(BR2_LINUX_KERNEL_CUSTOM_SVN),y)
+LINUX_SITE = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_REPO_URL))
+LINUX_SITE_METHOD = svn
 else
 LINUX_SOURCE = linux-$(LINUX_VERSION).tar.xz
 ifeq ($(BR2_LINUX_KERNEL_CUSTOM_VERSION),y)