qemu: needs pkg-config
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 4 Nov 2012 06:35:24 +0000 (06:35 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 5 Nov 2012 08:00:00 +0000 (09:00 +0100)
Fixes

  http://autobuild.buildroot.org/results/ccb7d6da503a81015275ff1e4ba9a564203932ec/build-end.log

Even though the build failure happens on host-qemu, adding
host-pkgconf to QEMU_DEPENDENCIES seems like the right thing to do
since that this dependency will also be needed for the target qemu
once it gets included.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qemu/qemu.mk

index de72e045b6f1734334d9a5562b1bfd17c4cc3d61..c2c4103f62c4f0622c934d6998e8e50be338eefd 100644 (file)
@@ -8,6 +8,8 @@ QEMU_VERSION = 1.2.0
 QEMU_SOURCE = qemu-$(QEMU_VERSION).tar.bz2
 QEMU_SITE = http://wiki.qemu.org/download
 
+QEMU_DEPENDENCIES = host-pkgconf
+
 #       BR ARCH         qemu
 #       -------         ----
 #       arm             arm
@@ -53,7 +55,7 @@ endif
 HOST_QEMU_TARGETS=$(QEMU_ARCH)-linux-user
 
 define HOST_QEMU_CONFIGURE_CMDS
-       (cd $(@D); ./configure                          \
+       (cd $(@D); $(HOST_CONFIGURE_OPTS) ./configure   \
                --target-list="$(HOST_QEMU_TARGETS)"    \
                --prefix="$(HOST_DIR)/usr"              \
                --interp-prefix=$(STAGING_DIR)          \