check: new package
authorGustavo Zacarias <gustavo.zacarias@free-electrons.com>
Sat, 19 Sep 2015 12:41:51 +0000 (09:41 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 19 Sep 2015 13:07:33 +0000 (15:07 +0200)
Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/check/Config.in [new file with mode: 0644]
package/check/check.hash [new file with mode: 0644]
package/check/check.mk [new file with mode: 0644]

index 45f234532f2acbb04b6ae34d086cf3fccbbfb448..1bd27592fd222c8b5da588e9a531f2e077ab198c 100644 (file)
@@ -111,6 +111,7 @@ menu "Development tools"
        source "package/binutils/Config.in"
        source "package/bsdiff/Config.in"
        source "package/bustle/Config.in"
+       source "package/check/Config.in"
        source "package/cmake/Config.in"
        source "package/cppunit/Config.in"
        source "package/cvs/Config.in"
diff --git a/package/check/Config.in b/package/check/Config.in
new file mode 100644 (file)
index 0000000..04682e1
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_CHECK
+       bool "check"
+       help
+         Check is a unit testing framework for C.
+
+         http://check.sourceforge.net/
diff --git a/package/check/check.hash b/package/check/check.hash
new file mode 100644 (file)
index 0000000..0c3a924
--- /dev/null
@@ -0,0 +1,3 @@
+# From http://sourceforge.net/projects/check/files/check/0.10.0/
+md5    53c5e5c77d090e103a17f3ed7fd7d8b8        check-0.10.0.tar.gz
+sha1   35d3a53446aea7b21a770faedb358d0fc7cba76d        check-0.10.0.tar.gz
diff --git a/package/check/check.mk b/package/check/check.mk
new file mode 100644 (file)
index 0000000..92dd033
--- /dev/null
@@ -0,0 +1,20 @@
+################################################################################
+#
+# check
+#
+################################################################################
+
+CHECK_VERSION = 0.10.0
+CHECK_SITE = http://downloads.sourceforge.net/project/check/check/$(CHECK_VERSION)
+CHECK_INSTALL_STAGING = YES
+CHECK_DEPENDENCIES = host-pkgconf
+CHECK_LICENSE = LGPLv2.1+
+CHECK_LICENSE_FILES = COPYING.LESSER
+
+# Having checkmk in the target makes no sense
+define CHECK_REMOVE_CHECKMK
+       rm -f $(TARGET_DIR)/usr/bin/checkmk
+endef
+CHECK_POST_INSTALL_TARGET_HOOKS += CHECK_REMOVE_CHECKMK
+
+$(eval $(autotools-package))