package/brcm-patchram-plus: new package
authorVadim Kochan <vadim4j@gmail.com>
Mon, 24 Dec 2018 17:28:47 +0000 (19:28 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 6 Feb 2019 14:57:09 +0000 (15:57 +0100)
Add tool which allows to setup broadcom bluetooth
device via UART.

Signed-off-by: Vadim Kochan <vadim4j@gmail.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
[Thomas: add hash for license file.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/brcm-patchram-plus/Config.in [new file with mode: 0644]
package/brcm-patchram-plus/brcm-patchram-plus.hash [new file with mode: 0644]
package/brcm-patchram-plus/brcm-patchram-plus.mk [new file with mode: 0644]

index e0340e851d6dfdb2fe5086812bab02ae2fbb03af..56d6e939c0aac644b701744d664c5fc0db5ba52f 100644 (file)
@@ -2149,6 +2149,9 @@ N:        Tzu-Jung Lee <roylee17@gmail.com>
 F:     package/dropwatch/
 F:     package/tstools/
 
+N:     Vadim Kochan <vadim4j@gmail.com>
+F:     package/brcm-patchram-plus/
+
 N:     Valentin Korenblit <valentinkorenblit@gmail.com>
 F:     package/clang/
 F:     package/clinfo/
index 9d023b94fe6e9b732d428dd9c5f9b0b23f9dd61e..cc232b9fba900a3b5d475c85b7452822a2890f20 100644 (file)
@@ -1821,6 +1821,7 @@ menu "Networking applications"
        source "package/bmon/Config.in"
        source "package/boa/Config.in"
        source "package/boinc/Config.in"
+       source "package/brcm-patchram-plus/Config.in"
        source "package/bridge-utils/Config.in"
        source "package/bwm-ng/Config.in"
        source "package/c-icap/Config.in"
diff --git a/package/brcm-patchram-plus/Config.in b/package/brcm-patchram-plus/Config.in
new file mode 100644 (file)
index 0000000..2742016
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_BRCM_PATCHRAM_PLUS
+       bool "brcm-patchram-plus"
+       help
+         Broadcom utility to flash Bluetooth firmwares, extended with
+         per-device Low Power Mode configuration.
+
+         https://github.com/AsteroidOS/brcm-patchram-plus
diff --git a/package/brcm-patchram-plus/brcm-patchram-plus.hash b/package/brcm-patchram-plus/brcm-patchram-plus.hash
new file mode 100644 (file)
index 0000000..fb7a91f
--- /dev/null
@@ -0,0 +1,3 @@
+# locally computed
+sha256  7d63f3a0c79cb5d187a0f2647734601f9c97d4eb8e545ce9ace7653c1f3f9a58  brcm-patchram-plus-94fb127e614b19a9a95561b8c1a0716e2e1e6293.tar.gz
+sha256  3bbeac0dc9f456695e692687c9d90a3c4ffc0253b0476d487d8cede207a8dc5b  src/main.c
diff --git a/package/brcm-patchram-plus/brcm-patchram-plus.mk b/package/brcm-patchram-plus/brcm-patchram-plus.mk
new file mode 100644 (file)
index 0000000..511ec99
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# brcm-patchram-plus
+#
+################################################################################
+
+BRCM_PATCHRAM_PLUS_VERSION = 94fb127e614b19a9a95561b8c1a0716e2e1e6293
+BRCM_PATCHRAM_PLUS_SITE = $(call github,AsteroidOS,brcm-patchram-plus,$(BRCM_PATCHRAM_PLUS_VERSION))
+BRCM_PATCHRAM_PLUS_LICENSE = Apache-2.0
+BRCM_PATCHRAM_PLUS_LICENSE_FILES = src/main.c
+BRCM_PATCHRAM_PLUS_AUTORECONF = YES
+
+$(eval $(autotools-package))