package/lvm2: lvmetad integration
authorPascal de Bruijn <p.debruijn@unilogic.nl>
Mon, 2 Mar 2020 07:49:50 +0000 (08:49 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 19 Apr 2020 20:39:58 +0000 (22:39 +0200)
lvmetad is usually combined with event-based system services that
automatically run pvscan --cache on disks added or removed.  This
way, the cache is automatically updated with metadata from new disks
when they appear.  LVM udev rules and systemd services implement this
automation.  Automatic scanning is usually combined with automatic
activation.  For more information, see pvscan(8).

Signed-off-by: Pascal de Bruijn <p.debruijn@unilogic.nl>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/lvm2/Config.in
package/lvm2/lvm2.mk

index de5b972e999f9b3fb8a65fe2a2ad42e20fbcb425..a41bb053b5c8840f9dedb3a8e54171fd75fd2b9d 100644 (file)
@@ -47,6 +47,19 @@ config BR2_PACKAGE_LVM2_APP_LIBRARY
 comment "lvm2 application library needs a glibc or uClibc toolchain"
        depends on BR2_TOOLCHAIN_USES_MUSL
 
+config BR2_PACKAGE_LVM2_LVMETAD
+       bool "install lvmetad"
+       select BR2_PACKAGE_LVM2_APP_LIBRARY
+       help
+         Install lvmetad
+
+         The lvmetad daemon caches LVM metadata so that LVM commands
+         can read metadata from the cache rather than scanning disks.
+         This can be an advantage because scanning disks is time
+         consuming and may interfere with the normal work of the
+         system.  lvmetad can be a disadvantage when disk event
+         notifications from the system are unreliable.
+
 endif
 
 comment "lvm2 needs a toolchain w/ threads, dynamic library"
index 02c758ea087fd899ea1cd48fab3c1275572bbe0f..76f800a15b17ef790690aea9f303fd43aab75859 100644 (file)
@@ -60,6 +60,12 @@ else
 LVM2_CONF_OPTS += --disable-applib
 endif
 
+ifeq ($(BR2_PACKAGE_LVM2_LVMETAD),y)
+LVM2_CONF_OPTS += --enable-lvmetad
+else
+LVM2_CONF_OPTS += --disable-lvmetad
+endif
+
 ifeq ($(BR2_INIT_SYSTEMD),y)
 LVM2_INSTALL_TARGET_OPTS += install_systemd_units install_systemd_generators
 endif