libpng: enable compilation on the host
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 20 Feb 2010 17:23:04 +0000 (18:23 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 23 Feb 2010 19:33:42 +0000 (20:33 +0100)
libpng is needed on the host to build ace_of_penguins.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libpng/libpng.mk

index 1297c89ee8421ddf14af44dd2dcd112ce89c376a..86e943caa5d6849099bcbd8c65fabc005fa26eff 100644 (file)
@@ -11,7 +11,12 @@ LIBPNG_INSTALL_STAGING = YES
 LIBPNG_CONF_OPT = --without-libpng-compat
 LIBPNG_DEPENDENCIES = host-pkg-config zlib
 
+HOST_LIBPNG_LIBTOOL_PATCH = NO
+HOST_LIBPNG_CONF_OPT = --without-libpng-compat
+HOST_LIBPNG_DEPENDENCIES = host-pkg-config host-zlib
+
 $(eval $(call AUTOTARGETS,package,libpng))
+$(eval $(call AUTOTARGETS,package,libpng,host))
 
 $(LIBPNG_HOOK_POST_INSTALL):
        $(SED) "s,^prefix=.*,prefix=\'$(STAGING_DIR)/usr\',g" \