linux: change CIP kernel download method
authorAngelo Compagnucci <angelo.compagnucci@gmail.com>
Wed, 20 Nov 2019 18:58:53 +0000 (19:58 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 20 Nov 2019 20:24:21 +0000 (21:24 +0100)
Downloading from https a tarball is faster than cloning a git repo.
If needed, BR2_LINUX_KERNEL_CUSTOM_GIT can be used as a fallback
mechanism to downlad the CIP kernel with git.

Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
linux/Config.in
linux/linux.mk

index d26bf1b14aff9650501b618bf3a7b1ba4ecde1c5..f6572f5fadce1f117b86bc0369f066b21c9fd951 100644 (file)
@@ -35,7 +35,7 @@ config BR2_LINUX_KERNEL_LATEST_VERSION
        bool "Latest version (5.3)"
 
 config BR2_LINUX_KERNEL_LATEST_CIP_VERSION
-       bool "Latest CIP SLTS version (v4.19.75-cip11)"
+       bool "Latest CIP SLTS version (4.19.75-cip11)"
        help
          CIP launched in the spring of 2016 to address the needs of
          organizations in industries such as power generation and
@@ -123,7 +123,7 @@ endif
 config BR2_LINUX_KERNEL_VERSION
        string
        default "5.3.8" if BR2_LINUX_KERNEL_LATEST_VERSION
-       default "v4.19.75-cip11" if BR2_LINUX_KERNEL_LATEST_CIP_VERSION
+       default "4.19.75-cip11" if BR2_LINUX_KERNEL_LATEST_CIP_VERSION
        default BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE \
                if BR2_LINUX_KERNEL_CUSTOM_VERSION
        default "custom" if BR2_LINUX_KERNEL_CUSTOM_TARBALL
index 89ac31c2e11eab1f1bf84ad52a3a701f3bdb80f8..c45db4d24ff2ab6302dbf6b74578df718c6d04cb 100644 (file)
@@ -30,7 +30,8 @@ else ifeq ($(BR2_LINUX_KERNEL_CUSTOM_SVN),y)
 LINUX_SITE = $(call qstrip,$(BR2_LINUX_KERNEL_CUSTOM_REPO_URL))
 LINUX_SITE_METHOD = svn
 else ifeq ($(BR2_LINUX_KERNEL_LATEST_CIP_VERSION),y)
-LINUX_SITE = git://git.kernel.org/pub/scm/linux/kernel/git/cip/linux-cip.git
+LINUX_SOURCE = linux-cip-$(LINUX_VERSION).tar.gz
+LINUX_SITE = https://git.kernel.org/pub/scm/linux/kernel/git/cip/linux-cip.git/snapshot
 else ifneq ($(findstring -rc,$(LINUX_VERSION)),)
 # Since 4.12-rc1, -rc kernels are generated from cgit. This also works for
 # older -rc kernels.