libupnpp: new package
authorJörg Krause <jkrause@posteo.de>
Tue, 21 Oct 2014 20:11:59 +0000 (22:11 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 22 Oct 2014 20:33:43 +0000 (22:33 +0200)
[Thomas: adjust dependencies on the comment.]

Signed-off-by: Jörg Krause <jkrause@posteo.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tested-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/libupnpp/Config.in [new file with mode: 0644]
package/libupnpp/libupnpp.mk [new file with mode: 0644]

index 89b46dce9f805d0166ea90a934530b48133510d3..4626f006106e49bdb016d444176366edf9e3980a 100644 (file)
@@ -816,6 +816,7 @@ menu "Networking"
        source "package/libtirpc/Config.in"
        source "package/libtorrent/Config.in"
        source "package/libupnp/Config.in"
+       source "package/libupnpp/Config.in"
        source "package/libvncserver/Config.in"
        source "package/libwebsockets/Config.in"
        source "package/neon/Config.in"
diff --git a/package/libupnpp/Config.in b/package/libupnpp/Config.in
new file mode 100644 (file)
index 0000000..5a48f97
--- /dev/null
@@ -0,0 +1,23 @@
+config BR2_PACKAGE_LIBUPNPP
+       bool "libupnpp"
+       select BR2_PACKAGE_EXPAT
+       select BR2_PACKAGE_LIBCURL
+       select BR2_PACKAGE_LIBUPNP
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_LARGEFILE # libupnp
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libupnp
+       depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2014R1 # Too old gcc
+       depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2013R1 # Ditto
+       depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2 # Ditto
+       help
+         The libupnpp C++ library wraps libupnp for easier use by upmpdcli and
+         upplay.
+
+         http://www.lesbonscomptes.com/upmpdcli/
+
+comment "libupnpp needs a toolchain w/ C++, largefile, threads"
+       depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2014R1 # Too old gcc
+       depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2013R1 # Ditto
+       depends on !BR2_TOOLCHAIN_EXTERNAL_BLACKFIN_UCLINUX_2012R2 # Ditto
+       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_LARGEFILE || \
+               !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/libupnpp/libupnpp.mk b/package/libupnpp/libupnpp.mk
new file mode 100644 (file)
index 0000000..d46de14
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# libupnpp
+#
+################################################################################
+
+LIBUPNPP_VERSION = 0.8.5
+LIBUPNPP_SITE = http://www.lesbonscomptes.com/upmpdcli/downloads
+LIBUPNPP_LICENSE = GPLv2+
+LIBUPNPP_LICENSE_FILES = COPYING
+LIBUPNPP_INSTALL_STAGING = YES
+LIBUPNPP_DEPENDENCIES = expat libcurl libupnp
+
+$(eval $(autotools-package))