configuring uClibc depends on first having kernel headers in place
authorEric Andersen <andersen@codepoet.org>
Tue, 18 Jul 2006 23:43:58 +0000 (23:43 -0000)
committerEric Andersen <andersen@codepoet.org>
Tue, 18 Jul 2006 23:43:58 +0000 (23:43 -0000)
Makefile
toolchain/uClibc/uclibc.mk

index c181aa7cc65c43deaf1d55b50e49f708a53f9432..e9d0ab8e286f121500acd6a475fea0603528317b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -43,7 +43,7 @@ ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
 # along with the packages to build for the target.
 #
 ##############################################################
-TARGETS:=kernel-headers uclibc-configured binutils gcc uclibc-target-utils
+TARGETS:=uclibc-configured binutils gcc uclibc-target-utils
 include toolchain/Makefile.in
 include package/Makefile.in
 
index 2caceebb49d91eb69b0d6bfdc64daf0bff2de78f..0cbefd8cd6bebcc1112bb64702e90e66290fa260 100644 (file)
@@ -68,7 +68,7 @@ $(UCLIBC_DIR)/.unpacked: $(DL_DIR)/$(UCLIBC_SOURCE)
        touch $(UCLIBC_DIR)/.unpacked
 
 uclibc-configured: $(UCLIBC_DIR)/.configured
-$(UCLIBC_DIR)/.configured: dependencies $(UCLIBC_DIR)/.unpacked
+$(UCLIBC_DIR)/.configured: dependencies kernel-headers $(UCLIBC_DIR)/.unpacked
        cp $(UCLIBC_CONFIG_FILE) $(UCLIBC_DIR)/.config
        $(SED) 's,^CROSS_COMPILER_PREFIX=.*,CROSS_COMPILER_PREFIX="$(TARGET_CROSS)",g' \
                -e 's,# TARGET_$(UCLIBC_TARGET_ARCH) is not set,TARGET_$(UCLIBC_TARGET_ARCH)=y,g' \