u-boot: fix custom patch dir handling
authorOssy <ossy1980@gmx.net>
Mon, 26 Jul 2010 20:45:48 +0000 (22:45 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 26 Jul 2010 20:45:48 +0000 (22:45 +0200)
Signed-off-by: Ossy <ossy1980@gmx.net>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
boot/u-boot/u-boot.mk

index 60a4676dc54ac049f66c856138ee2c9a41b4af5a..9eeea1d004f83c0cfff1543ae98613ac60eb4fab 100644 (file)
@@ -77,8 +77,8 @@ $(U_BOOT_DIR)/.patched: $(U_BOOT_DIR)/.unpacked
        toolchain/patch-kernel.sh $(U_BOOT_DIR) boot/u-boot \
                u-boot-$(U_BOOT_VERSION)-\*.patch \
                u-boot-$(U_BOOT_VERSION)-\*.patch.$(ARCH)
-ifneq ($(qstrip $(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR)),)
-       toolchain/patch-kernel.sh $(U_BOOT_DIR) $(U_BOOT_CUSTOM_PATCH_DIR) u-boot-$(U_BOOT_VERSION)-\*.patch
+ifneq ($(strip $(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR)),"")
+       toolchain/patch-kernel.sh $(U_BOOT_DIR) $(BR2_TARGET_UBOOT_CUSTOM_PATCH_DIR) u-boot-$(U_BOOT_VERSION)-\*.patch
 endif
        touch $@