linux: zImage target no longer available on x86
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 28 May 2010 10:03:56 +0000 (12:03 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 28 May 2010 10:03:56 +0000 (12:03 +0200)
The legacy zImage target for x86 was removed from the kernel in 2.6.30,
and we state in Config.in that we'll use bzImage if BR2_PACKAGE_LINUX_FORMAT
isn't set, so ensure we do so for x86.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
target/linux/Makefile.in
target/linux/Makefile.in.advanced

index 6983d2548f37f452563566fb0393c8134b3ab95f..f0198244069385f9e65e0fcce357da1becfea3ad 100644 (file)
@@ -10,7 +10,7 @@ ifeq ($(DOWNLOAD_LINUX26_VERSION),)
 # User did not define linux version, try using headers
 ifeq ($(LINUX_HEADERS_VERSION),)
 # We did not have headers (this is for real???)
-# Version of linuc before patches
+# Version of linux before patches
 DOWNLOAD_LINUX26_VERSION=2.6.22.1
 # Version of Linux after applying any patches
 LINUX26_VERSION=2.6.22.1
@@ -44,9 +44,14 @@ ifndef LINUX26_FORMAT
 ifneq ($(call qstrip,$(BR2_PACKAGE_LINUX_FORMAT)),)
 LINUX26_FORMAT=$(call qstrip,$(BR2_PACKAGE_LINUX_FORMAT))
 else
+ifneq ($(filter i386 x86-64,$(KERNEL_ARCH)),)
+# zImage target no longer available on x86 since 2.6.30
+LINUX26_FORMAT=bzImage
+else
 LINUX26_FORMAT=zImage
 endif
 endif
+endif
 
 # Has to be set by the target/device
 ifndef LINUX26_BINLOC
index 9e495f3e0f03108dd86f6aa771c2c95b696313df..86d94ca409c53ec005cd23a10fab04e5c743e21a 100644 (file)
@@ -111,9 +111,14 @@ ifndef LINUX26_FORMAT
 ifneq ($(call qstrip,$(BR2_PACKAGE_LINUX_FORMAT)),)
 LINUX26_FORMAT:=$(call qstrip,$(BR2_PACKAGE_LINUX_FORMAT))
 else
+ifneq ($(filter i386 x86-64,$(KERNEL_ARCH)),)
+# zImage target no longer available on x86 since 2.6.30
+LINUX26_FORMAT=bzImage
+else
 LINUX26_FORMAT:=zImage
 endif
 endif
+endif
 
 # -----------------------------------------------------------------------------
 # Has to be set by the target/device