busybox: PAM support needs thread support
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 4 Jul 2015 13:48:04 +0000 (15:48 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 4 Jul 2015 13:48:04 +0000 (15:48 +0200)
In commit f21b2558a097d07b53b6f20a47770468e9e4f7ed ("busybox: added
linux-pam support"), we added optional support for PAM in
Busybox. However, this support requires the toolchain to have thread
support, which causes build failures with non-thread capable
toolchains.

This commit therefore enables Busybox PAM support only if the
linux-pam package is available *and the toolchain has thread support.

Fixes:

  http://autobuild.buildroot.org/results/1a3/1a380aaca9303b67cc59165d56cf12f35966fe26/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/busybox/busybox.mk

index 34eb1f36547d152fd2f97e41b992f1d302744572..51b35bc8fd50f5f395c108b46fc09f6c37eb7762 100644 (file)
@@ -152,7 +152,8 @@ define BUSYBOX_INSTALL_WATCHDOG_SCRIPT
 endef
 endif
 
-ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
+# PAM support requires thread support in the toolchain
+ifeq ($(BR2_PACKAGE_LINUX_PAM)$(BR2_TOOLCHAIN_HAS_THREADS),yy)
 define BUSYBOX_LINUX_PAM
        $(call KCONFIG_ENABLE_OPT,CONFIG_PAM,$(BUSYBOX_BUILD_CONFIG))
 endef