package/python-traitlets: New package
authorAndrey Smirnov <andrew.smirnov@gmail.com>
Mon, 12 Jun 2017 23:42:10 +0000 (16:42 -0700)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 15 Jun 2017 20:47:31 +0000 (22:47 +0200)
Add 'traitlets'[1] package to Buildroot. Needed by IPython.

[1] https://pypi.python.org/pypi/traitlets

Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
DEVELOPERS
package/Config.in
package/python-traitlets/Config.in [new file with mode: 0644]
package/python-traitlets/python-traitlets.hash [new file with mode: 0644]
package/python-traitlets/python-traitlets.mk [new file with mode: 0644]

index 9a11f8bf832be2788bb9dd18cd6fc22bff39e85c..282952b40e8478edadbf53d2871ad517e5403ec0 100644 (file)
@@ -84,6 +84,7 @@ N:    Andrey Smirnov <andrew.smirnov@gmail.com>
 F:     package/python-decorator/
 F:     package/python-ipython-genutils/
 F:     package/python-simplegeneric/
+F:     package/python-traitlets/
 
 N:     Andy Kennedy <andy.kennedy@adtran.com>
 F:     package/libunwind/
index 529bd961010a4faa7287568dacba2acccda2f1b5..0967de14f74577cab7cc8a3014378626d18af6f3 100644 (file)
@@ -852,6 +852,7 @@ menu "External python modules"
        source "package/python-tomako/Config.in"
        source "package/python-toml/Config.in"
        source "package/python-tornado/Config.in"
+       source "package/python-traitlets/Config.in"
        source "package/python-treq/Config.in"
        source "package/python-twisted/Config.in"
        source "package/python-txaio/Config.in"
diff --git a/package/python-traitlets/Config.in b/package/python-traitlets/Config.in
new file mode 100644 (file)
index 0000000..f1804e5
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_PYTHON_TRAITLETS
+       bool "python-traitlets"
+       select BR2_PACKAGE_PYTHON_ENUM34 if BR2_PACKAGE_PYTHON # runtime
+       select BR2_PACKAGE_PYTHON_SIX  # runtime
+       select BR2_PACKAGE_PYTHON_IPYTHON_GENUTILS  # runtime
+       select BR2_PACKAGE_PYTHON_DECORATOR  # runtime
+       help
+         A configuration system for Python applications.
+
+         https://pypi.python.org/pypi/traitlets
diff --git a/package/python-traitlets/python-traitlets.hash b/package/python-traitlets/python-traitlets.hash
new file mode 100644 (file)
index 0000000..23aa159
--- /dev/null
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi/traitlets/json, sha256 locally computed
+md5 3068663f2f38fd939a9eb3a500ccc154 traitlets-4.3.2.tar.gz
+sha256 9c4bd2d267b7153df9152698efb1050a5d84982d3384a37b2c1f7723ba3e7835 traitlets-4.3.2.tar.gz
diff --git a/package/python-traitlets/python-traitlets.mk b/package/python-traitlets/python-traitlets.mk
new file mode 100644 (file)
index 0000000..c711bde
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-traitlets
+#
+################################################################################
+
+PYTHON_TRAITLETS_VERSION = 4.3.2
+PYTHON_TRAITLETS_SOURCE = traitlets-$(PYTHON_TRAITLETS_VERSION).tar.gz
+PYTHON_TRAITLETS_SITE = https://pypi.python.org/packages/a5/98/7f5ef2fe9e9e071813aaf9cb91d1a732e0a68b6c44a32b38cb8e14c3f069
+PYTHON_TRAITLETS_LICENSE = BSD-3-Clause
+PYTHON_TRAITLETS_LICENSE_FILE = COPYING.md
+PYTHON_TRAITLETS_SETUP_TYPE = distutils
+
+$(eval $(python-package))