ncurses: use $(TARGET_MAKE_ENV) when calling $(MAKE)
authorGustavo Zacarias <gustavo.zacarias@free-electrons.com>
Thu, 13 Oct 2016 22:13:25 +0000 (19:13 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 15 Oct 2016 12:17:00 +0000 (14:17 +0200)
Signed-off-by: Gustavo Zacarias <gustavo.zacarias@free-electrons.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ncurses/ncurses.mk

index 276482490cc611d890ece05fc81a3539709c0902..9555f1ed664fd328a0f681a072fd48cf236cea29 100644 (file)
@@ -127,9 +127,9 @@ endif
 # ncurses breaks with parallel build, but takes quite a while to
 # build single threaded. Work around it similar to how Gentoo does
 define NCURSES_BUILD_CMDS
-       $(MAKE1) -C $(@D) DESTDIR=$(STAGING_DIR) sources
+       $(TARGET_MAKE_ENV) $(MAKE1) -C $(@D) DESTDIR=$(STAGING_DIR) sources
        rm -rf $(@D)/misc/pc-files
-       $(MAKE) -C $(@D) DESTDIR=$(STAGING_DIR)
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(STAGING_DIR)
 endef
 
 ifneq ($(BR2_STATIC_LIBS),y)