package/libgudev: add gobject-introspection optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 18 Jul 2021 19:57:11 +0000 (21:57 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 21 Jul 2021 21:31:04 +0000 (23:31 +0200)
gobject-introspection is an optional dependency (which is enabled by
default) since at least version 219 and
https://gitlab.gnome.org/GNOME/libgudev/-/commit/43a593b5b4097b887e49eaacafbc1337bd709718

Fixes:
 - http://autobuild.buildroot.org/results/3bedc9fa3b14939825fb9cdebc6977057c3f6118

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libgudev/libgudev.mk

index 63d592f9ac70396e504b3d8f58dd358a1091b8cd..9aa64c2c22d6c8c4051b900a021e8c669c6cf06a 100644 (file)
@@ -13,4 +13,11 @@ LIBGUDEV_LICENSE = LGPL-2.1+
 LIBGUDEV_LICENSE_FILES = COPYING
 LIBGUDEV_CONF_OPTS = --disable-umockdev
 
+ifeq ($(BR2_PACKAGE_GOBJECT_INTROSPECTION),y)
+LIBGUDEV_CONF_OPTS += --enable-introspection
+LIBGUDEV_DEPENDENCIES += gobject-introspection
+else
+LIBGUDEV_CONF_OPTS += --disable-introspection
+endif
+
 $(eval $(autotools-package))