core: introduce "sdk" target to make a relocatable SDK
authorWolfgang Grandegger <wg@grandegger.com>
Sat, 22 Jul 2017 11:15:40 +0000 (13:15 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 22 Jul 2017 12:35:13 +0000 (14:35 +0200)
We use a separate make target to build a relocatable SDK. We first
sanitize the RPATH in host tree. Next we also sanitize the
staging tree. Therefore "sdk" must depend on world.

Sanitizing staging is not really needed, in the sense that any rpath
in there is simply not going to be used. We want to sanitize staging
for the following reasons:

- To avoid leaking references to the original output directory. This
  way, we can validate that the SDK is relocatable by running a simple
  "grep -r ${BASE_DIR} ${HOST_DIR}". Obviously RPATH sanitization is
  not sufficient (e.g. also the references to source files have to be
  stripped), but it's a step in the right direction. This reason is
  obviously only relevant for the SDK.

- To make sure that when an executable is copied to target that it
  actually executes correctly. Since within Buildroot we never copy
  stuff from staging to target, this is clearly only relevant for
  the SDK.

Finally we install the script "relocate-sdk.sh" into the top directory
of the SDK (HOST_DIR) and the SDK location path is stored in the file
"HOST_DIR/share/buildroot/sdk-location"-

Signed-off-by: Wolfgang Grandegger <wg@grandegger.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index d4faa021cd7e5c6dbdc8a8470ed4bdf4d0e11815..fc86a7071b1ee6bcfb83d6b3a9e88d1e859b4ab2 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -552,6 +552,14 @@ prepare: $(BUILD_DIR)/buildroot-config/auto.conf
 .PHONY: world
 world: target-post-image
 
+.PHONY: sdk
+sdk: world
+       @$(call MESSAGE,"Rendering the SDK relocatable")
+       $(TOPDIR)/support/scripts/fix-rpath host
+       $(TOPDIR)/support/scripts/fix-rpath staging
+       $(INSTALL) -m 755 $(TOPDIR)/support/misc/relocate-sdk.sh $(HOST_DIR)/relocate-sdk.sh
+       echo $(HOST_DIR) > $(HOST_DIR)/share/buildroot/sdk-location
+
 # Compatibility symlink in case a post-build script still uses $(HOST_DIR)/usr
 $(HOST_DIR)/usr: $(HOST_DIR)
        @ln -snf . $@
@@ -1001,6 +1009,7 @@ help:
        @echo 'Build:'
        @echo '  all                    - make world'
        @echo '  toolchain              - build toolchain'
+       @echo '  sdk                    - build relocatable SDK'
        @echo
        @echo 'Configuration:'
        @echo '  menuconfig             - interactive curses-based configurator'