package/gstreamer1/gst1-plugins-bad: wayland plugin needs libdrm
authorPeter Seiderer <ps.report@gmx.net>
Tue, 17 Dec 2019 19:15:01 +0000 (20:15 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 25 Dec 2019 22:10:51 +0000 (23:10 +0100)
Fixes:
  http://autobuild.buildroot.net/results/e06fbed25fc8369c2ff1f3d89b8800766e365ea3
  http://autobuild.buildroot.net/results/252d2d247339ee6f89ae2b813d33518d612dd9b3

  Run-time dependency wayland-client found: YES 1.17.0
  Run-time dependency libdrm found: NO (tried pkgconfig)
  gst-libs/gst/wayland/meson.build:3:0: ERROR: Dependency "libdrm" not found, tried pkgconfig

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gstreamer1/gst1-plugins-bad/Config.in
package/gstreamer1/gst1-plugins-bad/gst1-plugins-bad.mk

index 08952f70cb071ccc01dcdc13921c855cc3262274..393950ef2f6a723fdc9a0cf1394956b22fbb1cab 100644 (file)
@@ -555,6 +555,8 @@ config BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WAYLAND
        bool "wayland"
        default y
        depends on BR2_PACKAGE_WAYLAND
+       depends on BR2_TOOLCHAIN_HAS_THREADS #  libdrm -> libpthread-stubs
+       select BR2_PACKAGE_LIBDRM
        select BR2_PACKAGE_WAYLAND_PROTOCOLS
        help
          Wayland Video Sink
index 1d4ba62bd23b260f538fd061b2d477b52b938f27..259f00cdbbd13c6e04ddb5afdb3b8d0419774827 100644 (file)
@@ -66,7 +66,7 @@ GST1_PLUGINS_BAD_DEPENDENCIES = gst1-plugins-base gstreamer1
 
 ifeq ($(BR2_PACKAGE_GST1_PLUGINS_BAD_PLUGIN_WAYLAND),y)
 GST1_PLUGINS_BAD_CONF_OPTS += -Dwayland=enabled
-GST1_PLUGINS_BAD_DEPENDENCIES += wayland wayland-protocols
+GST1_PLUGINS_BAD_DEPENDENCIES += libdrm wayland wayland-protocols
 else
 GST1_PLUGINS_BAD_CONF_OPTS += -Dwayland=disabled
 endif