package/lldpd: fix readline dependency
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 10 Dec 2018 15:48:22 +0000 (16:48 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 13 Dec 2018 21:20:22 +0000 (22:20 +0100)
lldpd can optionally depend on readline, but readline is never added
to LLDPD_DEPENDENCIES, which this commit fixes.

This was detected using per-package directories.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/lldpd/lldpd.mk

index 939cd128faed5ff323eda87ee5b2f08e6691a7a1..6a520448da9bdb4950bd986b88f263b00d96924d 100644 (file)
@@ -36,7 +36,6 @@ LLDPD_CONF_OPTS = \
        --without-libbsd \
        --disable-hardening \
        --disable-privsep \
-       $(if $(BR2_PACKAGE_READLINE),--with-readline,--without-readline) \
        $(if $(BR2_PACKAGE_LLDPD_CDP),--enable-cdp,--disable-cdp) \
        $(if $(BR2_PACKAGE_LLDPD_FDP),--enable-fdp,--disable-fdp) \
        $(if $(BR2_PACKAGE_LLDPD_EDP),--enable-edp,--disable-edp) \
@@ -46,6 +45,13 @@ LLDPD_CONF_OPTS = \
        $(if $(BR2_PACKAGE_LLDPD_DOT3),--enable-dot3,--disable-dot3) \
        $(if $(BR2_PACKAGE_LLDPD_CUSTOM_TLV),--enable-custom,--disable-custom)
 
+ifeq ($(BR2_PACKAGE_READLINE),y)
+LLDPD_CONF_OPTS += --with-readline
+LLDPD_DEPENDENCIES += readline
+else
+LLDPD_CONF_OPTS += --without-readline
+endif
+
 define LLDPD_INSTALL_INIT_SYSV
        $(INSTALL) -D -m 0755 package/lldpd/S60lldpd \
                $(TARGET_DIR)/etc/init.d/S60lldpd