- normalize KERNEL_ARCH via sed
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Wed, 11 Oct 2006 11:36:57 +0000 (11:36 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Wed, 11 Oct 2006 11:36:57 +0000 (11:36 -0000)
toolchain/kernel-headers/kernel-headers.mk

index b49af2fb606adc0c49c743c22e4abf65121fa446..afad596ebbae94f1123188f25e8bdc37a8bdee77 100644 (file)
@@ -129,10 +129,15 @@ endif
 ifeq ($(LINUX_HEADERS_IS_KERNEL),y)
 # full kernel tarball >= 2.6.18
 
-KERNEL_ARCH:=$(shell $(SHELL) -c 'if test "$(ARCH)" = "i486" -o "$(ARCH)" = "i586"; then echo i386; else echo $(ARCH); fi')
+KERNEL_ARCH:=$(shell $(SHELL) -c "echo \"$(ARCH)\" | sed -e \"s/-.*//\" \
+       -e s/i.86/i386/ -e s/sun4u/sparc64/ \
+       -e s/arm.*/arm/ -e s/sa110/arm/ \
+       -e s/s390x/s390/ -e s/parisc64/parisc/ \
+       -e s/ppc.*/powerpc/ -e s/mips.*/mips/")
 
 $(LINUX_HEADERS_UNPACK_DIR)/.patched: $(LINUX_HEADERS_UNPACK_DIR)/.unpacked
        toolchain/patch-kernel.sh $(LINUX_HEADERS_UNPACK_DIR) toolchain/kernel-headers linux-$(LINUX_HEADERS_VERSION)\*.patch
+       touch $(LINUX_HEADERS_UNPACK_DIR)/.patched
 
 $(LINUX_HEADERS_DIR)/.configured: $(LINUX_HEADERS_UNPACK_DIR)/.patched
        (cd $(LINUX_HEADERS_UNPACK_DIR) ; \