python-daemon: add missing dependencies
authorYegor Yefremov <yegorslists@googlemail.com>
Wed, 21 Sep 2016 13:40:44 +0000 (15:40 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 21 Sep 2016 18:51:38 +0000 (20:51 +0200)
python-daemon package mentions python-docutils in both setup_requires
and instal_requires fields. So add related dependencies.

Fixes:
http://autobuild.buildroot.net/results/0c3/0c3866038f7c40888e5e440f7a720fc614a6b1ba/
http://autobuild.buildroot.net/results/5d8/5d817bddeff5bb49ed31c6a1d111974c358ef96c/
and many more.

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/python-daemon/Config.in
package/python-daemon/python-daemon.mk

index 8b6dcc05ed93a1923497c3164c858deae19c9c1b..21f44074526751f099e01c591ff2b80ff2da3af1 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_PYTHON_DAEMON
        bool "python-daemon"
+       select BR2_PACKAGE_PYTHON_DOCUTILS # runtime
        help
          Library to implement a well-behaved Unix daemon process.
 
index e85be9a97a7e664e890d64e7fc3a17780c705d6d..648d549ca8a7b0c22bfb78ba6b759f6dc7986bd0 100644 (file)
@@ -9,5 +9,6 @@ PYTHON_DAEMON_SITE = https://pypi.python.org/packages/source/p/python-daemon
 PYTHON_DAEMON_LICENSE = Apache-2.0 (library), GPLv3+ (test, build)
 PYTHON_DAEMON_LICENSE_FILES = LICENSE.ASF-2 LICENSE.GPL-3
 PYTHON_DAEMON_SETUP_TYPE = setuptools
+PYTHON_DAEMON_DEPENDENCIES = host-python-docutils
 
 $(eval $(python-package))