package/git-crypt: fix build with gcc-4.9
authorBernd Kuhls <bernd.kuhls@t-online.de>
Mon, 20 Aug 2018 19:40:56 +0000 (21:40 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 20 Aug 2018 20:24:59 +0000 (22:24 +0200)
Fixes

In file included from commands.cpp:32:0:
crypto.hpp:60:7: error: 'unique_ptr' in namespace 'std' does not name a template type
  std::unique_ptr<Aes_impl> impl;

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/git-crypt/git-crypt.mk

index 507534c139dec7058abae4028e83ccbf23726eb2..37e3d885a9489a481edb2d2be4340d46108f1047 100644 (file)
@@ -14,7 +14,8 @@ GIT_CRYPT_LIBS = `$(PKG_CONFIG_HOST_BINARY) --libs openssl`
 
 define GIT_CRYPT_BUILD_CMDS
        $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) \
-               LDFLAGS="$(TARGET_LDFLAGS) $(GIT_CRYPT_LIBS)" PREFIX=/usr
+               LDFLAGS="$(TARGET_LDFLAGS) $(GIT_CRYPT_LIBS)" \
+               CXXFLAGS="$(TARGET_CXXFLAGS) -std=c++11" PREFIX=/usr
 endef
 
 define GIT_CRYPT_INSTALL_TARGET_CMDS