collectd: disallow for static-only builds
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 19 Jul 2014 14:29:57 +0000 (16:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 19 Jul 2014 14:29:57 +0000 (16:29 +0200)
collectd doesn't really support static-only builds: each plugin
defines a module_register() function, and plugins are supposed to be
dynamically loaded.

Also, passing -lm in LIBS makes more sense than LDFLAGS, as it is
passed at the end of the build command line.

Fixes:

  http://autobuild.buildroot.org/results/047/047dc20aba46885679b6d21cdd2d77fc252374b6/

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/collectd/Config.in
package/collectd/collectd.mk

index a2e7877872c8bb1805f82b4cf8123a9a1f05cfbd..fbb4282d6135f8038f10314fed053aeb698619b5 100644 (file)
@@ -4,6 +4,7 @@ config BR2_PACKAGE_COLLECTD
        depends on BR2_USE_MMU
        depends on BR2_INET_IPV6
        depends on BR2_TOOLCHAIN_HAS_THREADS
+       depends on !BR2_PREFER_STATIC_LIB
        help
          collectd is a daemon which collects system performance
          statistics periodically and provides mechanisms to store
@@ -442,6 +443,6 @@ endmenu
 
 endif
 
-comment "collectd needs a toolchain w/ IPv6, threads"
-       depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_INET_IPV6
+comment "collectd needs a toolchain w/ IPv6, threads, dynamic library"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS || !BR2_INET_IPV6 || BR2_PREFER_STATIC_LIB
        depends on BR2_USE_MMU
index 84e17cdf6858c5bbbf6cc24bf4774a0c7eda4fac..90404060d4fe2480943cebaed2421e397a1ef07e 100644 (file)
@@ -21,15 +21,7 @@ COLLECTD_PLUGINS_DISABLE = amqp apple_sensors aquaero ascent dbi email \
                tokyotyrant uuid varnish vserver write_mongodb write_redis \
                xmms zfs_arc
 
-COLLECTD_LDFLAGS = $(TARGET_LDFLAGS) -lm
-
-ifeq ($(BR2_PREFER_STATIC_LIB),y)
-# collectd-tg indirectly needs pthread but doesn't link with -pthread,
-# causing static linker errors
-COLLECTD_LDFLAGS += -lpthread
-endif
-
-COLLECTD_CONF_ENV += LDFLAGS="$(COLLECTD_LDFLAGS)"
+COLLECTD_CONF_ENV += LIBS="-lm"
 
 COLLECTD_CONF_OPT += --with-nan-emulation --with-fp-layout=nothing \
        --localstatedir=/var --with-perl-bindings=no \