package/neon: properly enable expat
authorYann E. MORIN <yann.morin.1998@free.fr>
Mon, 29 Aug 2016 09:39:26 +0000 (11:39 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 29 Aug 2016 11:21:12 +0000 (13:21 +0200)
Currently, we forcibly tell neon's configure where to look for libexpat.
This means that neon does not search for it, and consequently forgets to
add -lexpat as its Libs.Private in its .pc file. As thus, a static link
against neon forgets to pull in -lexpat (it works for a dynamic link
because libneon has a NEEDED on libexpat).

The reason for specifying the explicit path in this case is lost to
history; neon's configure can correctly find libexpat nowadays.

Fixes:
    http://autobuild.buildroot.org/results/884/884746351fc47f4ad19fb3fda7c5e0ee85fcff15/
    http://autobuild.buildroot.org/results/0c5/0c584522c26640e29980150a87a5b5d8c02e5f8b/

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/neon/neon.mk

index 0cff1a26f827e34cf4434872932a55359f7aeb27..13d80844cca4064c2652e48de3f4319eab697881 100644 (file)
@@ -28,7 +28,7 @@ NEON_CONF_OPTS += --without-ssl
 endif
 
 ifeq ($(BR2_PACKAGE_NEON_EXPAT),y)
-NEON_CONF_OPTS += --with-expat=$(STAGING_DIR)/usr/lib/libexpat.la
+NEON_CONF_OPTS += --with-expat=yes
 NEON_DEPENDENCIES += expat
 else
 NEON_CONF_OPTS += --with-expat=no