Don't mess with the headers files installed by uClibc
authorEric Andersen <andersen@codepoet.org>
Wed, 5 Mar 2003 12:07:24 +0000 (12:07 -0000)
committerEric Andersen <andersen@codepoet.org>
Wed, 5 Mar 2003 12:07:24 +0000 (12:07 -0000)
make/system-linux.mk

index f12a8e1b593fe1577237635ee60ef3133c793eea..2f55dd5979fe7fe1be2961f714ff36fa2ae3b7ec 100644 (file)
@@ -47,19 +47,7 @@ $(LINUX_DIR)/.configured:
 
 $(LINUX_KERNEL): $(LINUX_DIR)/.configured
 
-$(STAGING_DIR)/include/linux/version.h: $(LINUX_DIR)/.configured
-       mkdir -p $(STAGING_DIR)/include
-       rm -rf $(STAGING_DIR)/include/linux
-       cp -dpa $(LINUX_DIR)/include/linux $(STAGING_DIR)/include/
-       rm -rf $(STAGING_DIR)/include/asm
-       mkdir -p $(STAGING_DIR)/include/asm
-       cp -dpa $(LINUX_DIR)/include/asm/* $(STAGING_DIR)/include/asm/
-       rm -rf $(STAGING_DIR)/include/scsi
-       mkdir -p $(STAGING_DIR)/include/scsi
-       cp -dpa $(LINUX_DIR)/include/scsi/* $(STAGING_DIR)/include/scsi
-       touch -c $(STAGING_DIR)/include/linux/version.h
-
-system-linux: $(STAGING_DIR)/include/linux/version.h
+system-linux: $(LINUX_DIR)/.configured
 
 system-linux-clean: clean
        rm -f $(LINUX_KERNEL)