package/erlang-jiffy: set version in jiffy.app.src
authorRomain Naour <romain.naour@gmail.com>
Sun, 4 Jun 2017 15:29:18 +0000 (17:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 5 Jun 2017 09:35:45 +0000 (11:35 +0200)
Fixes:
http://autobuild.buildroot.net/results/5c0/5c045a517ccdc97244a4cfca54465dc8d5fcc717

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: Johan Oudinet <johan.oudinet@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/erlang-jiffy/erlang-jiffy.mk

index 674c80f4b7c7a76a252dc80b1887e9a21c94a0a3..31394545460f4d7d3548005b7ecd101ac49fd216 100644 (file)
@@ -11,4 +11,10 @@ ERLANG_JIFFY_LICENSE = MIT (core), \
        BSD-3-Clause (tests)
 ERLANG_JIFFY_LICENSE_FILES = LICENSE
 
+# Set version manually in jiffy.app.src otherwise "git describe" is used.
+define ERLANG_JIFFY_SET_VERSION_HOOK
+       $(SED) 's/{vsn, git}/{vsn, "$(ERLANG_JIFFY_VERSION)"}/' $(@D)/src/jiffy.app.src
+endef
+ERLANG_JIFFY_POST_PATCH_HOOKS = ERLANG_JIFFY_SET_VERSION_HOOK
+
 $(eval $(rebar-package))