package/restorecond: Add new init script
authorJosé Pekkarinen <jose.pekkarinen@unikie.com>
Fri, 20 Aug 2021 11:23:22 +0000 (14:23 +0300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 20 Aug 2021 21:34:35 +0000 (23:34 +0200)
The current restorecond upstream init script is no good fit for the
user space generated by buildroot, so we provide our own one.

Signed-off-by: José Pekkarinen <jose.pekkarinen@unikie.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/restorecond/S02restorecond [new file with mode: 0644]
package/restorecond/restorecond.mk

diff --git a/package/restorecond/S02restorecond b/package/restorecond/S02restorecond
new file mode 100644 (file)
index 0000000..796b07a
--- /dev/null
@@ -0,0 +1,54 @@
+#!/bin/sh
+
+DAEMON=restorecond
+PIDFILE=/var/run/$DAEMON.pid
+
+RESTORECOND_ARGS=""
+
+# shellcheck source=/dev/null
+[ -r "/etc/default/$DAEMON" ] && . "/etc/default/$DAEMON"
+
+start()
+{
+       printf 'Starting %s: ' "$DAEMON"
+       start-stop-daemon -b -m -S -q -p "$PIDFILE" -x "/usr/sbin/$DAEMON" \
+               -- $RESTORECOND_ARGS
+       status=$?
+       if [ "$status" -eq 0 ]; then
+               echo "OK"
+       else
+               echo "FAIL"
+       fi
+       return "$status"
+}
+
+stop()
+{
+       printf 'Stopping %s: ' "$DAEMON"
+       start-stop-daemon -K -q -p $PIDFILE -R TERM/30/KILL/5 -n $DAEMON
+       status=$?
+       if [ "$status" -eq 0 ]; then
+               rm -f "$PIDFILE"
+               echo "OK"
+       else
+               echo "FAIL"
+       fi
+       return "$status"
+}
+
+restart()
+{
+       stop
+       sleep 1
+       start
+}
+
+case "$1" in
+       start|stop|restart)
+               "$1";;
+       reload)
+               restart;;
+       *)
+               echo $"Usage: $0 {start|stop|restart|reload}"
+               exit 1
+esac
index d08e0a722eddffda26e5fa520bb32245ef2f4a67..671f071b1d62d64c9d7d7002a66e4044dd32d94f 100644 (file)
@@ -27,8 +27,8 @@ define RESTORECOND_BUILD_CMDS
 endef
 
 define RESTORECOND_INSTALL_INIT_SYSV
-       $(INSTALL) -m 0755 -D $(@D)/restorecond.init \
-               $(TARGET_DIR)/etc/init.d/S20restorecond
+       $(INSTALL) -m 0755 -D package/restorecond/S02restorecond \
+               $(TARGET_DIR)/etc/init.d/S02restorecond
 endef
 
 define RESTORECOND_INSTALL_INIT_SYSTEMD