rtmpdump: don't force a crypto backend
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 27 Jan 2014 16:09:32 +0000 (17:09 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 27 Jan 2014 16:09:32 +0000 (17:09 +0100)
rtmpdump CAN work without a crypto backend (by passing CRYPTO=), so
don't enforce gnutls.

Fixes a dependency issue as gnutls needs wchar, but rtmpdump
(and polarssl/openssl) don't.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/rtmpdump/Config.in
package/rtmpdump/rtmpdump.mk

index c37118a458849015d980471027a254dd7ba5340a..5e9c50849f5acf8b0448d373d2bdbcebf1d6ca01 100644 (file)
@@ -1,7 +1,6 @@
 config BR2_PACKAGE_RTMPDUMP
        bool "librtmp"
        select BR2_PACKAGE_ZLIB
-       select BR2_PACKAGE_GNUTLS if !BR2_PACKAGE_POLARSSL && !BR2_PACKAGE_OPENSSL
        help
          rtmpdump - RTMPDump Real-Time Messaging Protocol API
          Only librtmp is installed by this package.
index 7ef9ff4578fc04bbe6328ef9bca2969505636ed2..4f9d2474c1955fdd9232964cc023d73b0a218779 100644 (file)
@@ -19,9 +19,12 @@ ifeq ($(BR2_PACKAGE_GNUTLS),y)
 else ifeq ($(BR2_PACKAGE_POLARSSL),y)
     RTMPDUMP_DEPENDENCIES += polarssl
     RTMPDUMP_CRYPTO = POLARSSL
-else
+else ifeq ($(BR2_PACKAGE_OPENSSL),y)
     RTMPDUMP_DEPENDENCIES += openssl
     RTMPDUMP_CRYPTO = OPENSSL
+else
+    # no crypto
+    RTMPDUMP_CRYPTO =
 endif
 
 RTMPDUMP_CFLAGS = $(TARGET_CFLAGS)