mesa3d: don't remove OpenGL pc when installing Gallium
authorAkihiko Odaki <akihiko.odaki.4i@stu.hosei.ac.jp>
Wed, 1 Jun 2016 06:58:35 +0000 (15:58 +0900)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 5 Jul 2016 13:03:46 +0000 (15:03 +0200)
Gallium driver also provides DRI-like infrastructure and OpenGL.
This change prevents from removing pkg-configs of them also when
installing the driver.

Signed-off-by: Akihiko Odaki <akihiko.odaki.4i@stu.hosei.ac.jp>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mesa3d/mesa3d.mk

index ebd674faa911691e06d4b1568b3b0bc9710b5b8e..117e06178d9f2bd1fe932ddb6a84778c267c4da6 100644 (file)
@@ -102,7 +102,6 @@ endef
 ifeq ($(BR2_PACKAGE_MESA3D_DRI_DRIVER),)
 MESA3D_CONF_OPTS += \
        --without-dri-drivers --disable-dri3
-MESA3D_POST_INSTALL_STAGING_HOOKS += MESA3D_REMOVE_OPENGL_PC
 else
 ifeq ($(BR2_PACKAGE_XPROTO_DRI3PROTO),y)
 MESA3D_DEPENDENCIES += xlib_libxshmfence xproto_dri3proto xproto_presentproto
@@ -125,6 +124,10 @@ MESA3D_CONF_OPTS += \
        --with-dri-drivers=$(subst $(space),$(comma),$(MESA3D_DRI_DRIVERS-y))
 endif
 
+ifeq ($(BR2_PACKAGE_MESA3D_GALLIUM_DRIVER)$(BR2_PACKAGE_MESA3D_DRI_DRIVER),)
+MESA3D_POST_INSTALL_STAGING_HOOKS += MESA3D_REMOVE_OPENGL_PC
+endif
+
 # APIs
 
 ifeq ($(BR2_PACKAGE_MESA3D_OSMESA),y)