package/nftables: bear the kernel options munging
authorAdam Duskett <Aduskett@gmail.com>
Thu, 7 May 2020 23:14:53 +0000 (16:14 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 24 Jun 2020 21:39:30 +0000 (23:39 +0200)
Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/nftables/nftables.mk

index 7f797797db7281e9b3192d960e6044fa3b39a7f3..c5503e2039011faadfea15077f85615f5a6917a4 100644 (file)
@@ -47,4 +47,10 @@ endif
 
 NFTABLES_CONF_ENV = LIBS="$(NFTABLES_LIBS)"
 
+define NFTABLES_LINUX_CONFIG_FIXUPS
+       $(call KCONFIG_ENABLE_OPT,CONFIG_NETFILTER)
+       $(call KCONFIG_ENABLE_OPT,CONFIG_NF_TABLES)
+       $(call KCONFIG_ENABLE_OPT,CONFIG_NF_TABLES_INET)
+endef
+
 $(eval $(autotools-package))