package/apg: new package
authorBernd Kuhls <bernd.kuhls@t-online.de>
Tue, 13 Jul 2021 19:13:59 +0000 (21:13 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Fri, 23 Jul 2021 22:06:46 +0000 (00:06 +0200)
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
DEVELOPERS
package/Config.in
package/apg/Config.in [new file with mode: 0644]
package/apg/apg.hash [new file with mode: 0644]
package/apg/apg.mk [new file with mode: 0644]

index 72d76b1f449c8dd49d627b9ccede1d7ba714c36a..596670993ad0a1d08eda7bd994a66ebf93b7edcd 100644 (file)
@@ -311,6 +311,7 @@ N:  Bernd Kuhls <bernd.kuhls@t-online.de>
 F:     package/alsa-lib/
 F:     package/alsa-utils/
 F:     package/apache/
+F:     package/apg/
 F:     package/apr/
 F:     package/apr-util/
 F:     package/bcg729/
index d4150f3cd6708863b364afa6f2dfc0df48263889..be701507642bed282b9bb011c137a506491b03c3 100644 (file)
@@ -2399,6 +2399,7 @@ comment "Shells"
        source "package/mksh/Config.in"
        source "package/zsh/Config.in"
 comment "Utilities"
+       source "package/apg/Config.in"
        source "package/at/Config.in"
        source "package/bash-completion/Config.in"
        source "package/ccrypt/Config.in"
diff --git a/package/apg/Config.in b/package/apg/Config.in
new file mode 100644 (file)
index 0000000..94c286a
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_APG
+       bool "apg"
+       help
+         Automated Password Generator (APG).
+
+         https://github.com/wilx/apg
diff --git a/package/apg/apg.hash b/package/apg/apg.hash
new file mode 100644 (file)
index 0000000..5532289
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally computed
+sha256  89539aa734a47d68124fca5ba7acbe559edc5003b6791f5200ef9e706dd00fe9  apg-2.3.0b.tar.gz
+sha256  5d0c892ea452c3828f1e311637cde4e3a04eb6431554308b3fcdac8c1b330168  COPYING
diff --git a/package/apg/apg.mk b/package/apg/apg.mk
new file mode 100644 (file)
index 0000000..ac4dce7
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# apg
+#
+################################################################################
+
+APG_VERSION = 2.3.0b
+APG_SITE = $(call github,wilx,apg,v$(APG_VERSION))
+APG_LICENSE = BSD-3-Clause
+APG_LICENSE_FILES = COPYING
+
+define APG_BUILD_CMDS
+       $(MAKE) $(TARGET_CONFIGURE_OPTS) CFLAGS="$(APG_CFLAGS)" \
+               -C $(@D)
+endef
+
+define APG_INSTALL_TARGET_CMDS
+       $(INSTALL) -D -m 0755 $(@D)/apg $(TARGET_DIR)/usr/bin/apg
+endef
+
+$(eval $(generic-package))