gettext: remove libintl handling
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 16 Sep 2012 12:57:48 +0000 (12:57 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Thu, 20 Sep 2012 19:27:40 +0000 (21:27 +0200)
Now, the gettext package always:

 * install everything to the staging directory
 * install the libraries to the target directory

Note that this commit removes BR2_PACKAGE_LIBINTL without updating the
packages, it is done in a separate commit to ease the review process.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tested-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
[yann.morin.1998@free.fr: keep BR2_PACKAGE_LIBINTL as blind option]
Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
CC: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/gettext/Config.in
package/gettext/gettext.mk

index 0ee4065c4d08e5d8d34ec94472f32c1c43416af7..04f7de673c19bb606bc9ce6da8de813cc094768c 100644 (file)
@@ -7,17 +7,15 @@ config BR2_PACKAGE_GETTEXT
          framework to help other GNU packages produce multi-lingual
          messages.
 
+         Only the gettext libraries will be installed in the
+         target. The full gettext suite, including tools, will be
+         installed in the staging directory.
+
          http://www.gnu.org/software/gettext/
 
 comment "gettext requires a toolchain with WCHAR support"
        depends on BR2_NEEDS_GETTEXT && !BR2_USE_WCHAR
 
 config BR2_PACKAGE_LIBINTL
-       bool "libintl"
-       depends on BR2_NEEDS_GETTEXT
-       depends on BR2_USE_WCHAR
-       help
-         Selecting this package installs all of gettext in the staging
-         directory and the shared library for it's use in the target.
-
-         http://www.gnu.org/software/gettext/
+       bool
+       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT
index 6b2c336d0b6a5adbd4db24ef9da85e5be358112d..4dff9416251014176e0b6fe1187ea880953d60a2 100644 (file)
@@ -112,7 +112,7 @@ $(STAGING_DIR)/$(GETTEXT_TARGET_BINARY): $(GETTEXT_DIR)/$(GETTEXT_BINARY)
 gettext-legal-info:
        @$(call legal-warning-pkg,gettext,legal-info not yet implemented)
 
-gettext: host-pkg-config $(if $(BR2_PACKAGE_LIBICONV),libiconv) $(STAGING_DIR)/$(GETTEXT_TARGET_BINARY)
+gettext: host-pkg-config $(if $(BR2_PACKAGE_LIBICONV),libiconv) $(STAGING_DIR)/$(GETTEXT_TARGET_BINARY) $(TARGET_DIR)/$(LIBINTL_TARGET_BINARY)
 
 gettext-unpacked: $(GETTEXT_DIR)/.unpacked
 
@@ -139,16 +139,11 @@ $(TARGET_DIR)/usr/lib/libintl.so: $(STAGING_DIR)/$(GETTEXT_TARGET_BINARY)
                libgettext*.so*.la libintl*.so*.la)
        touch -c $@
 
-libintl: $(TARGET_DIR)/$(LIBINTL_TARGET_BINARY)
-
 #############################################################
 #
 # Toplevel Makefile options
 #
 #############################################################
-ifeq ($(BR2_PACKAGE_LIBINTL),y)
-TARGETS+=libintl
-endif
 ifeq ($(BR2_PACKAGE_GETTEXT),y)
 TARGETS+=gettext
 endif