* Fixed uClibc sub-x86 arch selection
authorNigel Kukard <nkukard@lbsd.net>
Sat, 29 Mar 2008 16:23:16 +0000 (16:23 -0000)
committerNigel Kukard <nkukard@lbsd.net>
Sat, 29 Mar 2008 16:23:16 +0000 (16:23 -0000)
toolchain/uClibc/uclibc.mk

index b9f73bcd08c1cd2f765d7d112d95729fceaa3472..21411ce6a4831065e91e2e4d56495562f8971b83 100644 (file)
@@ -353,7 +353,31 @@ ifeq ($(BR2_x86_i486),y)
 endif
 ifeq ($(BR2_x86_i586),y)
        $(SED) 's,# CONFIG_586 is not set,CONFIG_586=y,g' $(UCLIBC_DIR)/.oldconfig
-endif
+endif 
+ifeq ($(BR2_x86_pentium_mmx),y)
+       $(SED) 's,# CONFIG_586MMX is not set,CONFIG_586MMX=y,g' $(UCLIBC_DIR)/.oldconfig
+endif 
+ifeq ($(BR2_x86_pentium2),y)
+       $(SED) 's,# CONFIG_PENTIUMII is not set,CONFIG_PENTIUMII=y,g' $(UCLIBC_DIR)/.oldconfig
+endif 
+ifeq ($(BR2_x86_pentium3),y)
+       $(SED) 's,# CONFIG_PENTIUMIII is not set,CONFIG_PENTIUMIII=y,g' $(UCLIBC_DIR)/.oldconfig
+endif 
+ifeq ($(BR2_x86_pentium4),y)
+       $(SED) 's,# CONFIG_PENTIUM4 is not set,CONFIG_PENTIUM4=y,g' $(UCLIBC_DIR)/.oldconfig
+endif 
+ifeq ($(BR2_x86_pentium_m),y)
+       $(SED) 's,# CONFIG_PENTIUM4 is not set,CONFIG_PENTIUM4=y,g' $(UCLIBC_DIR)/.oldconfig
+endif 
+ifeq ($(BR2_x86_pentiumpro),y)
+       $(SED) 's,# CONFIG_PENTIUM4 is not set,CONFIG_PENTIUM4=y,g' $(UCLIBC_DIR)/.oldconfig
+endif 
+ifeq ($(BR2_x86_nocona),y)
+       $(SED) 's,# CONFIG_PENTIUM4 is not set,CONFIG_PENTIUM4=y,g' $(UCLIBC_DIR)/.oldconfig
+endif 
+ifeq ($(BR2_x86_core2),y)
+       $(SED) 's,# CONFIG_PENTIUM4 is not set,CONFIG_PENTIUM4=y,g' $(UCLIBC_DIR)/.oldconfig
+endif 
 ifeq ($(BR2_x86_i686),y)
        $(SED) 's,# CONFIG_686 is not set,CONFIG_686=y,g' $(UCLIBC_DIR)/.oldconfig
 endif