yaml-cpp: new package
authorSebastien Bourdelin <sebastien.bourdelin@savoirfairelinux.com>
Mon, 20 Oct 2014 15:11:18 +0000 (11:11 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 22 Oct 2014 21:03:53 +0000 (23:03 +0200)
yaml-cpp is a YAML parser and emitter in C++ matching
the YAML 1.2 spec.

https://code.google.com/p/yaml-cpp/

Signed-off-by: Sebastien Bourdelin <sebastien.bourdelin@savoirfairelinux.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/yaml-cpp/Config.in [new file with mode: 0644]
package/yaml-cpp/yaml-cpp.hash [new file with mode: 0644]
package/yaml-cpp/yaml-cpp.mk [new file with mode: 0644]

index 4626f006106e49bdb016d444176366edf9e3980a..d6cd8767c420c8d7506b2b828e6cc6f980db39e5 100644 (file)
@@ -737,6 +737,7 @@ menu "JSON/XML"
        source "package/tinyxml/Config.in"
        source "package/xerces/Config.in"
        source "package/yajl/Config.in"
+       source "package/yaml-cpp/Config.in"
 endmenu
 
 menu "Logging"
diff --git a/package/yaml-cpp/Config.in b/package/yaml-cpp/Config.in
new file mode 100644 (file)
index 0000000..d6afdac
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_YAML_CPP
+       bool "yaml-cpp"
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_LARGEFILE # boost
+       depends on BR2_TOOLCHAIN_HAS_THREADS # boost
+       select BR2_PACKAGE_BOOST
+       help
+         yaml-cpp is a YAML parser and emitter in C++ matching
+         the YAML 1.2 spec.
+
+         https://code.google.com/p/yaml-cpp/
+
+comment "yaml-cpp needs a toolchain w/ C++, largefile, threads"
+       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_LARGEFILE || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/yaml-cpp/yaml-cpp.hash b/package/yaml-cpp/yaml-cpp.hash
new file mode 100644 (file)
index 0000000..391e317
--- /dev/null
@@ -0,0 +1,5 @@
+# hash from: https://yaml-cpp.googlecode.com/files/yaml-cpp-0.5.1.tar.gz:
+sha1 9c5414b4090491e96d1b808fe8628b31e625fdaa  yaml-cpp-0.5.1.tar.gz
+
+# Locally calculated:
+sha256 3e7c9052b43d987d41819a203d97fc45de4eed3ec67e0fdb14265c3d11046f06  yaml-cpp-0.5.1.tar.gz
diff --git a/package/yaml-cpp/yaml-cpp.mk b/package/yaml-cpp/yaml-cpp.mk
new file mode 100644 (file)
index 0000000..5ebdb23
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# yaml-cpp
+#
+################################################################################
+
+YAML_CPP_VERSION = 0.5.1
+YAML_CPP_SITE = https://yaml-cpp.googlecode.com/files
+YAML_CPP_INSTALL_STAGING = YES
+YAML_CPP_LICENSE = MIT
+YAML_CPP_LICENSE_FILES = license.txt
+
+$(eval $(cmake-package))