package/gdb: add support for host-gdb with python3
authorRamon Fried <rfried.dev@gmail.com>
Mon, 23 Mar 2020 06:46:21 +0000 (08:46 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 11 Apr 2020 13:42:46 +0000 (15:42 +0200)
host-gdb was limited to link only with Python 2 although it's possible
to build Python 3 for host. Add the ability to link with Python 3.

Signed-off-by: Ramon Fried <rfried.dev@gmail.com>
[Thomas: add an option to the choice to not have Python support]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gdb/Config.in.host
package/gdb/gdb.mk

index 2db73b10d65f344b862c5b0bcc7ad119db1b0cbe..8de7f8395b48ab5b5766f2cfb3b9af157043fc61 100644 (file)
@@ -32,10 +32,28 @@ config BR2_PACKAGE_HOST_GDB_TUI
        help
          This option enables terminal user interface (TUI) for gdb
 
+choice
+       prompt "Python support"
+       default BR2_PACKAGE_HOST_GDB_NOPYTHON
+       help
+         Select the version of Python you wish to use
+
+config BR2_PACKAGE_HOST_GDB_NOPYTHON
+       bool "None"
+       help
+         This option disables Python support in the cross gdb.
+
 config BR2_PACKAGE_HOST_GDB_PYTHON
-       bool "Python support"
+       bool "Python 2"
        help
-         This option enables the Python support in the cross gdb.
+         This option enables the Python 2 support in the cross gdb.
+
+config BR2_PACKAGE_HOST_GDB_PYTHON3
+       bool "Python 3"
+       help
+         This option enables the Python 3 support in the cross gdb.
+
+endchoice
 
 config BR2_PACKAGE_HOST_GDB_SIM
        bool "Simulator support"
index 01f7e14460a0962723307b4327bbb3632c6cf409..8c74a0e2f67b1b24569a7185dc8aaaaab3d9882a 100644 (file)
@@ -238,6 +238,9 @@ endif
 ifeq ($(BR2_PACKAGE_HOST_GDB_PYTHON),y)
 HOST_GDB_CONF_OPTS += --with-python=$(HOST_DIR)/bin/python2
 HOST_GDB_DEPENDENCIES += host-python
+else ifeq ($(BR2_PACKAGE_HOST_GDB_PYTHON3),y)
+HOST_GDB_CONF_OPTS += --with-python=$(HOST_DIR)/bin/python3
+HOST_GDB_DEPENDENCIES += host-python3
 else
 HOST_GDB_CONF_OPTS += --without-python
 endif