package/libarchive: add lz4 optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 28 Feb 2020 22:12:35 +0000 (23:12 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 25 Apr 2020 19:21:03 +0000 (21:21 +0200)
lz4 is available since version 3.2.0 and
https://github.com/libarchive/libarchive/commit/724f3f918e509ddca60ce62fad696d7621d3623d

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libarchive/libarchive.mk

index 94f974e7d1109df31a2c454c20edb5b0868250e5..20863f9ba989bf1b80764af4ab72061675555496 100644 (file)
@@ -79,6 +79,13 @@ else
 LIBARCHIVE_CONF_OPTS += --without-xml2
 endif
 
+ifeq ($(BR2_PACKAGE_LZ4),y)
+LIBARCHIVE_CONF_OPTS += --with-lz4
+LIBARCHIVE_DEPENDENCIES += lz4
+else
+LIBARCHIVE_CONF_OPTS += --without-lz4
+endif
+
 ifeq ($(BR2_PACKAGE_LZO),y)
 LIBARCHIVE_DEPENDENCIES += lzo
 else
@@ -131,6 +138,7 @@ HOST_LIBARCHIVE_CONF_OPTS = \
        --without-expat \
        --without-libiconv-prefix \
        --without-xml2 \
+       --without-lz4 \
        --without-lzo2 \
        --without-mbedtls \
        --without-nettle \