package/janet: new package
authorFrancois Perrad <fperrad@gmail.com>
Sat, 13 Feb 2021 11:39:28 +0000 (12:39 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 16 Feb 2021 21:10:52 +0000 (22:10 +0100)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/janet/Config.in [new file with mode: 0644]
package/janet/janet.hash [new file with mode: 0644]
package/janet/janet.mk [new file with mode: 0644]

index 7666493ddcf2b01e47fff89712e60c33cd8c3eb0..cee62ddca8994a8ae06b7eca303f41e0c2a65405 100644 (file)
@@ -920,6 +920,7 @@ F:  package/copas/
 F:     package/coxpcall/
 F:     package/dado/
 F:     package/ficl/
+F:     package/janet/
 F:     package/libtomcrypt/
 F:     package/libtommath/
 F:     package/libwpe/
index 5304ab141c0f08b497ea4f07d11473a570df2857..8fb173540fb5debba6523ed343294311da52b89e 100644 (file)
@@ -624,6 +624,7 @@ endif
        source "package/gauche/Config.in"
        source "package/guile/Config.in"
        source "package/haserl/Config.in"
+       source "package/janet/Config.in"
        source "package/jimtcl/Config.in"
        source "package/lua/Config.in"
        source "package/luainterpreter/Config.in"
diff --git a/package/janet/Config.in b/package/janet/Config.in
new file mode 100644 (file)
index 0000000..0e25ce3
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_JANET
+       bool "janet"
+       help
+         Janet is a functional and imperative programming language.
+         The entire language (core library, interpreter, compiler,
+         assembler, PEG) is less than 1MB. You can also add Janet
+         scripting to an application by embedding a single C file
+         and two headers.
+
+         https://janet-lang.org/
diff --git a/package/janet/janet.hash b/package/janet/janet.hash
new file mode 100644 (file)
index 0000000..4a1167f
--- /dev/null
@@ -0,0 +1,5 @@
+# Locally calculated
+sha256  e2cf16b330e47c858a675ac79b5a0af83727ff041efcb133a80f36bedfae57c4  janet-1.15.0.tar.gz
+
+# Locally calculated
+sha256  1114e280d850605ae71b656dfc88115ab06081e8157720a2497f50edf50b110e  LICENSE
diff --git a/package/janet/janet.mk b/package/janet/janet.mk
new file mode 100644 (file)
index 0000000..7243d60
--- /dev/null
@@ -0,0 +1,22 @@
+################################################################################
+#
+# janet
+#
+################################################################################
+
+JANET_VERSION = 1.15.0
+JANET_SITE = $(call github,janet-lang,janet,v$(JANET_VERSION))
+JANET_LICENSE = MIT
+JANET_LICENSE_FILES = LICENSE
+
+JANET_INSTALL_STAGING = YES
+
+ifeq ($(BR2_STATIC_LIBS),y)
+JANET_CONF_OPTS += -Ddynamic_modules=false
+endif
+
+ifeq ($(BR2_TOOLCHAIN_HAS_THREADS),)
+JANET_CONF_OPTS += -Dsingle_threaded=true
+endif
+
+$(eval $(meson-package))