package/python-avro: new package
authorTitouan Christophe <titouan.christophe@railnova.eu>
Mon, 23 Dec 2019 17:23:57 +0000 (18:23 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 29 Dec 2019 18:09:30 +0000 (19:09 +0100)
Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>
Reviewed-by: Gilles Talis <gilles.talis@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
DEVELOPERS
package/Config.in
package/python-avro/Config.in [new file with mode: 0644]
package/python-avro/python-avro.hash [new file with mode: 0644]
package/python-avro/python-avro.mk [new file with mode: 0644]

index ef11bdaaa095b8ed76d2ac9b9c2d6fe395053f26..1931b3e9428689a75fffc2e181a37686e773bd89 100644 (file)
@@ -2425,6 +2425,7 @@ F:        package/fbgrab/
 N:     Titouan Christophe <titouan.christophe@railnova.eu>
 F:     package/avro-c/
 F:     package/mosquitto/
+F:     package/python-avro/
 F:     package/redis/
 
 N:     Trent Piepho <tpiepho@impinj.com>
index c438669c3d64656b342dae2c9173c70c250a3774..6aac0f7e26d1bb617a665a7ff2fac72ea21b8fc1 100644 (file)
@@ -855,6 +855,7 @@ menu "External python modules"
        source "package/python-attrs/Config.in"
        source "package/python-autobahn/Config.in"
        source "package/python-automat/Config.in"
+       source "package/python-avro/Config.in"
        source "package/python-babel/Config.in"
        source "package/python-backcall/Config.in"
        source "package/python-backports-abc/Config.in"
diff --git a/package/python-avro/Config.in b/package/python-avro/Config.in
new file mode 100644 (file)
index 0000000..e1d7fc8
--- /dev/null
@@ -0,0 +1,20 @@
+config BR2_PACKAGE_PYTHON_AVRO
+       bool "python-avro"
+       depends on BR2_PACKAGE_PYTHON3
+       help
+         Select this option to install the Avro Python3 language
+         bindings, and the `avro` command line tool
+
+         Apache Avro is a data serialization system.
+         Avro provides:
+         - Rich data structures.
+         - A compact, fast, binary data format.
+         - A container file, to store persistent data.
+         - Remote procedure call (RPC).
+         - Simple integration with dynamic languages.
+         - Code generation is not required to read or write data
+           files nor to use or implement RPC protocols.
+         - Code generation as an optional optimization,
+           only worth implementing for statically typed languages.
+
+         http://avro.apache.org/
diff --git a/package/python-avro/python-avro.hash b/package/python-avro/python-avro.hash
new file mode 100644 (file)
index 0000000..f63b37e
--- /dev/null
@@ -0,0 +1,5 @@
+# From https://www-eu.apache.org/dist/avro/avro-1.9.1/py3/avro-python3-1.9.1.tar.gz.sha512
+sha512 771ce6e5ca6315f5b9108cb4f5dd9488575cc3433ffdd744f96ce7989763728259c89475319fd9c411ed6b65c996b762548c50a697eb1fba9ab024112ca17daa  avro-python3-1.9.1.tar.gz
+
+# License files
+sha256 c79a7fea0e3cac04cd43f20e7b648e5a0ff8fa5344e644b0ee09ca1162b62747  avro/LICENSE
diff --git a/package/python-avro/python-avro.mk b/package/python-avro/python-avro.mk
new file mode 100644 (file)
index 0000000..3f9140e
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-avro
+#
+################################################################################
+
+PYTHON_AVRO_VERSION = $(AVRO_C_VERSION)
+PYTHON_AVRO_SITE = https://www-eu.apache.org/dist/avro/avro-1.9.1/py3
+PYTHON_AVRO_SOURCE = avro-python3-$(PYTHON_AVRO_VERSION).tar.gz
+PYTHON_AVRO_LICENSE = Apache-2.0
+PYTHON_AVRO_LICENSE_FILES = avro/LICENSE
+PYTHON_AVRO_SETUP_TYPE = setuptools
+
+$(eval $(python-package))