gdb: build gdbserver with TARGET_MAKE_ENV
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 3 Feb 2013 02:30:22 +0000 (02:30 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 4 Feb 2013 22:35:07 +0000 (23:35 +0100)
This commit fixes the exact same problem than
21a0c11a90f9ff19c78a5f32e0a2e9064fd28054, but for the gdbserver
build. The problem is that when you use the Crosstool-NG toolchain
backend, gawk gets built as a dependency of Crosstool-NG. So the gdb
configure scripts detects it, and assumes it is in the PATH (because
the gdb configure step gets run with TARGET_MAKE_ENV).

But then, the build fails, because it tries to run gawk, but gawk
isn't in the PATH, because we forget to use this TARGET_MAKE_ENV
variable when building gdbserver.

Fixes http://autobuild.buildroot.org/results/d0173de533b5e2fffed2eff7327a502ed2d787cd/build-end.log

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
toolchain/gdb/gdb.mk

index 4b8fe3a3d55c9a7331b12c1502159efe3a439163..a932b1fab1541ab7d4ba2e3568bf3e298234e849 100644 (file)
@@ -144,6 +144,7 @@ $(GDB_SERVER_DIR)/.configured: $(GDB_DIR)/.unpacked
        touch $@
 
 $(GDB_SERVER_DIR)/gdbserver: $(GDB_SERVER_DIR)/.configured
+       $(TARGET_MAKE_ENV) \
        $(MAKE) CC="$(TARGET_CC)" MT_CFLAGS="$(TARGET_CFLAGS)" \
                -C $(GDB_SERVER_DIR)